Jump to content

ANSWERED Terribly slow FSS download speeds


Recommended Posts

Hello Gents,


 


This is an unashamed moan - but not at Orbx, at FSS.


 


I bought FTX Norway today and have been trying constantly to download my product, however the only download options available are the "Global CDN 1 & 2" options (there are no 'My FTX' or 'Google Cloud' options), and the offered download speeds all day have been horribly slow.


 


I am currently getting under 100kb/s, and am being quoted that it will take 3 days to download FTX Norway's 3.6Gb files.  :blink:


 


To me this is a wholly unacceptable service.   I am on a Fibre Optic High Speed Broadband connection and have verified no issues at my end.  I purchased a product from Simmarket today that was 4Gb is size and in contrast it took 30 mins to download.......


 


Not for the first time and due to the same issue, I find myself wishing that Orbx offered an alternative download provider for products, than FSS.


 


Yours frustratedly,


Link to post
Share on other sites

UPDATE :-


 


 


after constant failed downloads, I attempted to use FlashGet download manager to download FTX Norway.  It ran for just under 4 hours, reaching 66.9% of the download, before then reporting a dropped connection from FSS, and a 0kb/s download speed.   ::)


 


Still not able to download my FTX Norway purchase from FSS.   


 


FTX Norway is still the main 'banner' product shown on the front page of the Orbx website, and yet two of the usual FSS servers aren't available at all, and the two that are "CDN Global 1&2" have been so slow and unreliable today, that it's not been possible to get the product at all.


 


Very disappointing service.


Link to post
Share on other sites

Hi David,

Although I can relate to your frustration about your download speeds, there isn't anything we here can do about it, there where more members with slow speeds and it all trickled down to their provider capping their downloads specifically with large files or an overzealous Antivirus scanner

have read here => http://www.orbxsystems.com/forum/topic/91689-au-content-to-us-server/

Link to post
Share on other sites

I downloaded FTX EU NOR the other day using 155Mb/sec Virgin Media Fibre in the south of England and it took about 7 minutes for the whole lot. I can check the download again shortly and confirm this speed is still available.

I use a download manager called GetRight. The free version of this app allows you to use up to four concurrent links to the same server and file which effectively quadruples your download speed.

Link to post
Share on other sites

I'll add Internet Download Manager (IDM) to the list of download helpers. I've been using the full version for a fair while now and can't live without it. It also handles moving completed files to sensible folders/locations, so keeping track of your various downloads is easy.


 


Apart from re-booting your PC, have you tried powering off/rebooting your *router*? Sometimes their IP look-up tables can get stuffed up.


 


Adam.


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...