Jump to content

resolved Error Orbx Central Worker at newly installed Win10 pc


Recommended Posts

Just installed P3D4.5 and Orbx Central at my brandnew pc.
It looks like Orbx Central dóes download the files, but runs stuck with installing or updating them.
I found an older topic with the samen problem, but the solutions handed over there, do not have any improving effect at my pc.
At all downloading  and installing products, it says 80% and it stays like that. Some say 70%
I do not know if it is relevant, but ...Glass also starts installing again and again, in a separate screen outside Orbx Central

How can I solve this problem?
Thanks for the help!
Bram Stikkel

Error Notification.png

Link to post
Share on other sites

Ik did install the latest .net files, by the way.
The adviced older ones were or unfindable or "not suited for this pc".
The difficult thing is also, there are often more then one option for download, with one titel on which one searches.
Mayby I took the wrong one. But it is scary to 'make dirty' a just new pc with older software, anyway, thats how it feels B)  

Link to post
Share on other sites

Sorry for not thinking of telling everything at one message
My system is fast enough. Intel 10900K, RTX 2080 Super en 32Gb werkgeheugen 3600.
Furthermore enough diskspace for the backup files and the temporary unpack location.
 

Link to post
Share on other sites

Hello Nick,
Thanks for your reply. Indeed I use Windows 10.
Virus software being the problem, is unlikely because I have always used the same software (AVG) and never had any problems with Orbx Central before.
But I will test it without AVG beïng active and let you know.
Kind regards
Bram

Link to post
Share on other sites

Hello Nick,
I am flabbergasted. I really never expected it to solve the problem, but your advice to switch of all security seems to have solved the problem indeed.
It looks like everything is updating fine now.
Thank you VERY much for your advice!!!
Kind regards
Bram Stikkel

Link to post
Share on other sites

Some files still have problems, I now discover.
Again the 80% stop.
The Scenery Library in example

Also the Reallight and Trueglass apps and Objectflow
When the Reallight and Trueglass apps are trying to install, very shortly there is a .net installation screen popping up, only half a second.
It disappears to quick to have a good look at it.

I will wait now untill every product that is updating now, has finished.
Mayby the problem solves itself then.

Kind regards
Bram Stikkel

Link to post
Share on other sites

Hello NIck,
Although it seemed like things went well after switching of my virus scanner internet security, at the end, there are still the same amount of products that have to be installed or updated. They all 'hang' at the phase "Finaliizing and Cleaning up. Configuring. Again with the 80% indication in the cirkels behind the product names.

Also some installations say, the Scenery Library must be installed first, but doing so does result in the same situation as with all other installations: it stops at 80%
Even while the antivirus is switched off completely. So, this seems to point at a certain phase of the process in installing that cannot be done because of a lack of some prerequisite software. The problem with those software is, some of the mentioned ones are not available anymore, or one has to chose from about six versions to download.
I have allready done that and I am very afraid of damaging the Windowssystem by installing a to old piece of software, mostly Visual Basic versions or .NET files.
Is there anyone who can give a list of the nowadays with the latest WIndows 10 version prerequisite software, if possible with links to download them, and if with more choises, which one should be downloaded and installed.

I really do not know anymore.
 

I added two screenshots, to show what I see, described above.
KInd regards
Bram


 

Example situation installation Bella Coola with 80percent indication.png

Nitification during install Trueglass with Visual C++ screen very shortly shown.png

Link to post
Share on other sites

Because the Visual C++ 2015 was not able to install, I have executed a repair-action available in the installer.
Also did that voor the older and 2017 version, just in case Orbx Central Worker needs them too.
Result:  Installation of the Libraries still comes to a complete stop at the same moment. 

I then downloaded, installed and ran the Microsoft repairtool for .NET framework.
The first repairround appeared not to have solved the case. The second repairround results in a message, it cannot repair the problems and it will sent log files to Microsoft.

Now I will search for a way to completely uninstall Microsoft .NET files and reinstall them

Ofcourse if there is a better solution, I 'll be happy to follow your instructions
Kind regards

Link to post
Share on other sites

Hello,

I am guessing really but it looks like something is stopping the copying and pasting of files into your

P3D folder and perhaps into your appdata and programdata folders.

If you have not already, please set Orbx Central to always run as an administrator and lower your

Windows User Account Control to its lowest level and try again.

Link to post
Share on other sites

Have just run a Microsoft .net verifier tool. All present versions are installed correct.
That's good. The only question that remains, is what versions does OrbxCentral and Orbx Central Worker need?
I am going to search the forum again on this question.

Can  you or someone else see in the log file what happens or what does not happen in the last stage?

Regards,
Bram

Link to post
Share on other sites

Searching throug the forum in the section Orbx Central, I have not been able to find any uptodate  listing of prerequisite software for Orbx Central.
Could this be created ?

Tested Orbx Central with X-Plane 11 at the same pc. This works well. Installation goes fluent.
So, this would point in a direction you - Nick - already mentioned. Only, how to find the cause and solve it...
Very strange.
 

Link to post
Share on other sites

Well, here's the list of things I did after all the previous attempts. End of story is still, it does not work, at least for the P3Dv4 products.
The one free X-Plane 11 and one Microsoft Flight Simulator 2020 addons do install fine. By the way, also when the antivirus was on.

So, it is something specific in relation to P3Dv4.
 

I have tried this time:
changed the securitysettings from the external usb-3 drive on which Orbx Central is to install it's files. Set all things allowed for all users.
changed the securitysettings from the P3Dv4 directory in which the main programm is located.
Unfortunately, as I said, it does stil not solve the problem. Downloading goes fine, Finalizing and Cleaning up + Configuring does not.

I have switched of the checking for enough space. There is enough space, at the downloadlocation and unpacking location, at the backupfile location and at the final library location.

Do you think it is possible, to involve an specialist on Orbx Central to have a look at this problem, you think?

Greetings
Bram Stikkel

 



 

Flnalizing and Cleaning up and Configuring does not work.png

Link to post
Share on other sites

Yesterdag I found the manual of Orbx Central (yes, I am not different from most people, reading the manual as a last option ^_^) and there I found the files that are prerequisite for good functioning of Orbx Central. These are only 2 for WIndows 10. One of them was an update, that was not yet installed.
Unfortunately, it did not solve the  problem.

And it does stil not explain the well functioning of Orbx Central with Microsoft FS2020 and X-Plane 11 and disfunctioning for P3Dv4.

I know you do your best, Nick, and there is no way a complain in this to you personal. But since this forum is the only support channel for Orbx products,
maybe it would be a good idea, to involve some software programmers in the support, a kind of second level support for the harder to solve problems.
They know in depth how a program works and I suppose they could determine exactly were the cause of the problem must be.
Is this possible? 
Realizing there are a lot of requests and a lot of pc- and softwareconfigurations ;)

Kind regards
Bram
 

Link to post
Share on other sites

 

O, that is great news. Thanks for explaining me.
I can be patient...
A friend of mine suggested it might only seam to go okay with the downloads, instead of realy go okay.
Therefore I checked the content of the in Central set download location and it was empty.
Could this be an indication for the cause ?

Thanks again!
Bram Stikkel

Link to post
Share on other sites

Hi @Bram Stikkel

 

 

The log file indicates that it can't create a folder in order to complete the installation. Does the G:\Program Files\Lockheed Martin\Prepar3D v4\ORBX\FTX_AU\FTXAA_ORBXLIBS\Scenery  folder exist and if so does your user account have permission to create files at this location?

 

2021-01-28T12:48:51.169Z [INFO] [Saturn] - Extract chunk D:\Tenp install space ORBX\ORBXtemp\octemp\chunks\d7337139-a6ca-45b0-b39b-263fc18aeb4b.c.zip
2021-01-28T12:48:51.180Z [INFO] [Saturn] - [ERROR] Unable to create directory G:\Program Files\Lockheed Martin\Prepar3D v4\ORBX\FTX_AU\FTXAA_ORBXLIBS\Scenery
2021-01-28T12:48:51.183Z [INFO] [Saturn] - System.IO.DirectoryNotFoundException: Could not find a part of the path 'G:\Program Files\Lockheed Martin\Prepar3D v4\ORBX\FTX_AU\FTXAA_ORBXLIBS\Scenery'.
2021-01-28T12:48:51.183Z [INFO] [Saturn] -    at System.IO.FileSystem.CreateDirectory(String fullPath)
2021-01-28T12:48:51.183Z [INFO] [Saturn] -    at System.IO.Directory.CreateDirectory(String path)
2021-01-28T12:48:51.183Z [INFO] [Saturn] -    at Saturn.Jobs.Install.MainSubStages.ExtractSubStage.ExtractChunk(InboundChunk chunk)
2021-01-28T12:48:51.183Z [INFO] [Saturn] - [ERROR] Failed to copy file to the destination: G:\Program Files\Lockheed Martin\Prepar3D v4\ORBX/FTX_AU/FTXAA_ORBXLIBS/Scenery/Orbxlibs_P3D_PF1_human.bgl
2021-01-28T12:48:51.186Z [INFO] [Saturn] - System.IO.DirectoryNotFoundException: Could not find a part of the path 'G:\Program Files\Lockheed Martin\Prepar3D v4\ORBX\FTX_AU\FTXAA_ORBXLIBS\Scenery\Orbxlibs_P3D_PF1_human.bgl'.
2021-01-28T12:48:51.186Z [INFO] [Saturn] -    at System.IO.FileStream.ValidateFileHandle(SafeFileHandle fileHandle)
2021-01-28T12:48:51.186Z [INFO] [Saturn] -    at System.IO.FileStream.CreateFileOpenHandle(FileMode mode, FileShare share, FileOptions options)
2021-01-28T12:48:51.186Z [INFO] [Saturn] -    at System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share, Int32 bufferSize, FileOptions options)
2021-01-28T12:48:51.186Z [INFO] [Saturn] -    at Saturn.Jobs.Install.MainSubStages.ExtractSubStage.ExtractChunk(InboundChunk chunk)


 

 

Link to post
Share on other sites

Hello Josh,

FIrst, thank you very much for helping me by reading the log. I now see, how I might be able to read it myself in the future.

The mentioned link, does exist, but appears to lead to nothing. That is to say, the Orbx directory in the P3dV4 directory, appears to be a link to H:/Orbx which is a separate drive from which I have do the installation of P3Dv4. There is no directory Orbx directory there and there should not be one there.
My Orbx files are located in a external drive E Orbx-scenery.
That is the external drive on which I set Orbx Central to put all three directories for X-Plane 11, P3Dv4 and Microsoft Flight Simulator.

So the link in P3Dv4 directory to the external Orbx scenery location seems spontaniously have been created wrong. Strange thing is also, the latest modified date of the Orbx link in P3Dv4 is 12-june 2019. One would expect that, if I would have manually put older files in the P3Dv4 directory, but I have not. It is a clean new install.

I also wrote to Nick Cooper, the installation of Orbx freeware field Fairways Airport went okay. However, checking out how things were linked to the external drive in MSFS, I discovered, also there is a dead link, in the Community directory. Orbx-airport-og20-fairways appeared to link to a wrong directory. This one I can explain, because it points to the directory Orbx Central created in first instance. Later I changed in Orbx the location of the Orbx directory for MSFS and after that, the link in MSFS communityfolder should actually need to be updated. Appearently this change of location is not automatically set through in the flightsims directory Orbx link.

Can you tell me what is the best way to correct the links to the correct location of the Orbx scenery folder?
Can I just delete the wrong ones in the flightsims directories and create a correct one manually?
In that case: the directory on the external scenery drive looks like this: Orbx scenery/p3dv4/ and Orbx scenery/XP11 and Orbx scenery/msfs.
The location "Orbx scenery" I have named myself. The locations within that location Orbx Central created.
Should I create a link in the P3Dv4 game directory that is pointed to Orbx scenery/p3dv4/ then?

And the scenery library in P3Dv4 itself, how do I correct the locations there?

Thanks again very much!
Bram Stikke;


 

Link to post
Share on other sites

Okay, it looks like I solved the problem. Absolutely thanks to your help, Nick and Josh.
I have replaced the wrong pointed link in the P3Dv4 directory by a symbolic link to the P3Dv4 directory at the external harddisk and changed the name of the virual link in Orbx.
Now manual installtions and updates seem to work well.
Only auto update does not work, but that might be solved when the next update of products is coming.
Thanks again, both of you!
KInd regards
Bram Stikkel

Link to post
Share on other sites

Thanks, Nick, But I would not have managed without both your help.

Actually it would be great if Orbx would create a kind of easy-to-check data-base with all the possible causes from various problems.
Or do these things not happen often? And the help-function would be far better if it would link to directly related parts of the forum, depending on the error-message.

Thank you very much again and until later!
Bram Stikkel





 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...