Jump to content

Recommended Posts

So after a day of messing around trying to find out why this is extremely unflyable, as in all axis are crazy unstable I figured I would reach out to see if other had this problem. I have run nearly every sensitivity setting across X, Y and Z to no avail - some forums indicate for some there is no problem and many others are experiencing the same as myself. Just curious as to the perceptions of others here? 

Link to post
Share on other sites

I would go to windows control panel where you can test (and usualy also calibrate) the joystick. Move your axis and see how the cross is behaving. If its not fluid here and you see "spikes" in various directions, like it would stutter, you probably have some dirt inside the hotas.

 

Dust collects there, hairs and whatever, and it can happen that this influences the behavior. You have to open it in that case. But be careful....

 

Depending on what hotas there are lightsensors that are used for the controls and if a hair or something blocks the light path you have the problem you got.

 

Not saying thats the problem for you but one of the possible reasons.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...