Jump to content

active Object Flow preventing P3D to open


Recommended Posts

Hi all,

 

The issue i had with ESSA is related to object flow.

I tried a couple of thing before posting here.

 

The issue : When Object Flow is installed P3DV5 would launch until splashscreen then closes without warning.

If OF is uninstalled P3D works fine but Orbx Airports (ESSA< KSAN) have crap ground textures.

 

I tried :

1/ Uninstall my Orbx stuff (library, Global, ESSA, KSAN), then re install + verify = same issue

2/ Uninstall my Orbx stuff, create a new library folder + install libraries and Object Flow only = issue is persistent and P3D won't open.

 

ANy guidance will be much appreciated.

 

Everything works just fine with P3DV4.5

 

 

Link to post
Share on other sites

Hello,

objectflow does not normally affect P3D in this way.

Can you see any kind of error message?

If not, try renaming your Prepar3D.cfg file and see if it will load.

Hint: when testing, all that needs to be done is to tick or untick the add-ons entry and restart the simulator.

Similarly with scenery.

There is never a need to waste time uninstalling just to see if something works without something.

Link to post
Share on other sites

Hi Nick,

I have a similar problem, I have checked all the system files and no errors.

Also tried renaming p3d.cfg as you suggested.

I only get the ucrtbase.dll with objectflow enabled.

I am not computer literate enough to replace the ucrtbase file with an older version. 

Kind regards

Shane

Link to post
Share on other sites

@Nick Cooper

 

I tried all of above without success ...nothing worked

I reinstalled P3d (Client Scenery Content) no success

Finally reading the forum applied the following :

 

Go to the ObjectFlow folder (depend where you set the library as ObjectFlow is not installed in default P3D folder - in my case library is set to below folder) :

 

C:\Users\[YourName]\Orbx Library\p3dv5\Orbx ObjectFlow

 

copy this folder to 

 

C:\Users\[YourName]\Documents\Prepar3D v5 Add-ons\

 

delete in this folder /bin folder

 

and edit add-on.xml the path pointing the path to your library ObjectFlow folder path.

 

<?xml version="1.0" encoding="utf-8"?>
<SimBase.Document Type="AddOnXml" version="4,0" id="add-on">
  <AddOn.Name>Orbx ObjectFlow</AddOn.Name>
  <AddOn.Description>Allows Orbx scenery to display dynamic content.</AddOn.Description>
  <AddOn.Component>
    <Category>DLL</Category>
    <Path>C:\Users\[YourName]\Orbx Library\p3dv5\Orbx ObjectFlow\bin\Orbx_ObjectFlow_v3.dll</Path>  
    <DLLType>PDK</DLLType>
    <DLLStartName>module_init</DLLStartName>
    <DLLStopName>module_deinit</DLLStopName>
  </AddOn.Component>
</SimBase.Document>

 

 

It worked!!!!!!!!!!!!

 

 

Something to look at on the dev side.

 

 

Link to post
Share on other sites

Hi @Nick Cooper

I was optimitic...it was late yesterday when i tried in the dll path above i missed the right drive...when i corrected i can confirm i am still facing the same issue with objectflow:

  •  - when OF it's installed or active i double click to launch P3D  i have the splashscreen and then after 5 to 10 sec without warnings it crashes and disappears.
  • - As soon as i inhibit ObjectFlow P3d starts  normally if i go to ESSA  i can see the buildings but i am missing the ground textures , this happens despite changing the library folder, after P3d client  re install

I am realizing now that i was flying without the Orbx products being fully active. It's frustrating

I am out of ideas, and seeking help to get my sim to work with Orbx.

 

I don't see what is the difference with P3dV4 as it is installed the same way, probably APIs or dll config.

Edited by KlausL73
Link to post
Share on other sites

I can confirm that p3dv5 starts with KlausL73 workaround because the objectflow dll is not present but issues like at ESSA are still present

There is a direct conflict with objectflow dll and ucrtbase.dll

 

Edited by shane25
Link to post
Share on other sites

Hello,

it is not a workaround, is is just a way of inadvertently disabling objectflow.

 

The best place to install objectflow is in an Orbx Central Library that is not inside any

of the folders created by the installation of Windows.

 

If you do not have such a folder, please create C:\Orbx Central Library and add it to Orbx Central

as a new library.

Then uninstall objectflow from wherever it is now and if an attempt has been made to "work around",

delete every trace of that as well.

Once done, install objectflow into C:\Orbx Central Library and try again.

 

In case there are also remnants of previous installations, please take a look at this topic as well.

 

 

 

 

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...