Jump to content

Recommended Posts

Way back in this thread Nick said 'Orbx products go through a 'process' when being sold on the Market place. I wouldn't mind having a half a crown on Microsoft cocking up perfectly good Orbx gear during this 'process'. A friend is suffering the same as the rest of you Marketplace shoppers, whilst the two of use trying to help him have no problems whatsoever! We, of course /smug mode on, bought through Orbx Central \smug mode off.

Would it be lovely if you could transfer those purchases to Orbx Central?

Lesson to be learned. Buy direct from developers.

2c

  • Like 2
Link to post
Share on other sites

I have breaking news.

 

Another user reports the following:

 

image.thumb.png.7387f106f31c6e68cb44eaaf5d3c5222.png

My version which I bought from MSFS marketplace is 1.0.2.

This user reports he used to have the same problem as mine, but not any longer, after updating it from the earlier version to the newest 1.1.0 (as shown in his picture above). He bought it from Orbx Central. 

 

Therefore, imo it's definitely an issue with the MSFS marketplace, and its slow update digestion and feeding pace.

Edited by EvidencePlz
  • Thanks 1
Link to post
Share on other sites

I am also having a CTD problem. I purchased LOWI from Orbx Direct about an hour ago and it went through the Orbx installation process. Orbx LOWI was found to be installed in the in the community folder after installation. I loaded a flightplan EDDM > LOWI and in that process MSFS crashed. I have not had any crashes on start up like this before. There appears to be some type of conflict with the new install and MSFs. I then checked the official/store folder and found another LOWI file. I deleted that one assuming this might solve the problem but it did not. After going through the same process loading the same flightplan and using the Bonanza the CTD's continued. I am looking for assistance with this problem.

Thank you , Rolf

Link to post
Share on other sites

Nick, Thank you. I deleted the rolling cache. Loading flight plans to Lowi from vrs airports seem to work yet EDDM to LOWI does not. Just at the end of the flightplan loading, MSFS crashes. I have to get a better understanding how the general/graphics/data  section works. Starting at LOWI shows off the beautiful scenery. 

Any other ideas are welcome. 

Link to post
Share on other sites
10 hours ago, Rolfspan said:

Nick, Thank you. I deleted the rolling cache. Loading flight plans to Lowi from vrs airports seem to work yet EDDM to LOWI does not. Just at the end of the flightplan loading, MSFS crashes. I have to get a better understanding how the general/graphics/data  section works. Starting at LOWI shows off the beautiful scenery. 

Any other ideas are welcome. 

I might be able to help if you are willing to post a complete list of all your addons, both free and payware.

Link to post
Share on other sites

Hello,

there are far too many suspects in that list.

Can you confirm that if you rename that Community folder and then make a new one containing only Orbx LOWI,

uninstall or delete the Asobo LOWI, delete your Content.xml file and restart MSFS, there is no CTD?

If there is still a CTD, did you change or add any files in the Official folder while adding any of your myriad "mods"?

  • Like 1
Link to post
Share on other sites

Hi Nick, I did as you said and I had no CTD. I used the same flight plan as yesterday leaving the default EDDM en route to Orbx LOWI. Almost there and all appears good.

The next steps will be to try it with the full community folder. Thanks for your help. Rolf

  • Like 1
  • Thanks 1
Link to post
Share on other sites

I used the full Community folder again and unfortunately the CTD occurred again. That likely means that Orbx LOWI is fine as is EDDM which I had used in the past. Other flightplans from various departure airports show no problem. only EDDM > LOWI. The CTD happens at the end of the installation of the FP and before the sim accepts it. So does it mean it could be a conflict with one of the other airports I have recently installed. This is likely however how does one identify the faulty airport? 

Thanks 

Rolf

 

Link to post
Share on other sites

Hello,

I think it is likely, but I cannot at present see an answer except to find it by trial and error.

I understand that would take a very long time and even then, there is no guarantee that the next

simulator update would not change things again.

 

In your position, I think that splitting your large collection of scenery into parts, so that only those parts

that were required for the flight in question were loaded would be a good idea.

You should also bear in mind that if a problem is related to an aircraft livery, that aircraft can appear as

an AI or static at an airport and cause a problem that is not as obvious as using the texture on the aircraft being flown. 

 

It can be done by simply creating numerous Community folders, each with a slightly different name,

adding a number at the end would be the easiest way.

Otherwise, there are freeware scenery organisers that have been made available that can do this for you.

@Jon Clarke uses one of them, I believe and may well come along and advise you.

Link to post
Share on other sites

Nick's last post ( https://orbxsystems.com/forum/topic/203357-tacoma-narrows-ctd/?do=findComment&comment=1735997 ) is excellent, and the advice contained in it is pretty much the only thing you can do at the moment. I mean that's what I did to solve (albeit temporarily) solve the Orbx KTIW vs PP EGTB issue. 

 

I wouldn't be surprised at all if Nick one day is given some sort of OBE award for everything's he's done so far for home desktop flight simulation.

 

Link to post
Share on other sites

I would be more than willing to assist in the use of the freeware addon manager I use.

I attach an example pic of how I utilise the freeware programme to sort addons by aircraft/liveries/Regional scenery and utilities. I can enable and disable any part of those addon categories when I want to fly. The programme just adds symbolic links of the chosen addons to the Community folder. Fail safe from any potential loss of an addon as the original download/installation of the addons are kept away from the Community folder.

Not only does this allow me to just choose the relevant addons per flight but makes the load time very quick. I don't need scenery from the USA being loaded or looked for when I am flying in Europe for example.

Capture.thumb.JPG.23c421078a50a1c4feb6e72e443a7cc1.JPG

  • Like 1
  • Upvote 1
Link to post
Share on other sites

Gentlemen, After some troubleshooting I found that EDDM (Simwing) previously installed and working,  disappeared from the community folder somehow. I went to the website to find that EDDM was a problem and that an updated Version was available. I installed the updated version did all that was recommendation (Contents Manager /Rolling cache deletion)  and the problem I had disappeared. I truly appreciate the help you offered and i learned a lot during this process. My next steps will be to organize my community folder. Addon Linker here I come.

That is a great recommendation. Again my thanks. 

Rolf

  • Like 3
  • Thanks 1
Link to post
Share on other sites
  • 2 weeks later...
On 1/2/2021 at 12:20 PM, Ardbeg1977 said:

 

After hours of troubleshooting, I found that if I uninstall Flightbeam KDEN, which I purchased from the MSFS Marketplace, I am able to launch a flight from EGTB. So, some change that has been made to this scenery has conflicted with EGTB.

 

 

Update: This problem seems to have been fixed. There was an update download for EGTB and I am able to launch a flight from there, now, with Flightbeam KDEN installed, as well.

  • Like 1
Link to post
Share on other sites
9 hours ago, EvidencePlz said:

I'm pleased to announce that my CTD issue (described above) involving Orbx KTIW and Pilot Plus EGTB is now 100% solved after installing today’s marketplace update for the latter.

I just updated to version 1.12 of Wycombe Air Park on marketplace, and it appears it isn't fixed.  However, if I remove Wycombe Air Park and London Southend (both Pilot Plus products) the sim still CTDs at and around Tacoma.  If I remove Orbx Tacoma Narrows and add the Pilot Plus products in, the Tacoma area loads fine.  This suggests to me there is now a conflict with some other DLC, but the common factor is Orbx Tacoma Narrows.

 

In between downloading updates and testing this out I've spent 1 1/2 hours already this morning, and I can't afford to spend any more time on it for now.  I'm regretfully going to have to uninstall Orbx Tacoma Narrows for the time being.

Edited by Majickthyse
  • Like 1
Link to post
Share on other sites

Hello I am still having this issue and anytime I try to load at Tacoma Narrows or even near it I get a CTD. I have been trying to get this scenery to work for some time now. I have removed everything from my community folder and the problem still persists. 

Edited by Adrian Blandori
more detail
Link to post
Share on other sites
6 hours ago, Majickthyse said:

In between downloading updates and testing this out I've spent 1 1/2 hours already this morning, and I can't afford to spend any more time on it for now.  I'm regretfully going to have to uninstall Orbx Tacoma Narrows for the time being.

 

I feel and share your frustration, trust me. But please don't give up on troubleshooting. The devs need as much data as possible. MSFS 2020 is a bleeding edge product that will keep moving forward and that's a great thing, but it also has its consequences and we will have to grit our teeth and suffer it. In your case, EGTB and Southend are no longer a factor we can safely conclude. So it's high time we find out which other addon is clashing with KTIW.

 

One thing for sure though: Microsoft needs to turn up the marketplace's speed at which it digests third party's updates and content. Steam and DCS World were plagued with this exact same 'slow update' dilemma (although it didn't result in CTDs afaik) and it took a while for them to fix. I'm planning on writing a formal letter to MS asking them to look into this matter. 

Link to post
Share on other sites
4 minutes ago, EvidencePlz said:

 

So it's high time we find out which other addon is clashing with KTIW.

 

 

I guess my concern is that it 'takes two to tango' where there are DLC conflicts.

 

I've installed many other DLCs since this issue was raised and could spend days swapping them out to get to the root of it.  I've paid a lot of money for this sim and all it's DLCs and I'd actually like to spend my time playing it :D.  What I'm seeing now is Tacoma Narrows installed, area around it CTDs:  Tacoma Narrows removed, happy days! 

 

The answer moving on isn't just to remove things which conflict with Orbx Tacoma, or get the other developers to fix them.  We've had an interlude waiting while Pilot Plus fix their product, but now I think Orbx needs to get to the bottom of what is happening with Tacoma Narrows as well.  Maybe Orbx could talk to Pilot Plus - that might provide some pointers?

Link to post
Share on other sites

as with XP because of the nature of so many free downloadable content there will be issues, some freeware devs are not as thorough as others and some don't update their products when the sim needs it to be done.....

  • Like 1
Link to post
Share on other sites
1 hour ago, Majickthyse said:

I guess my concern is that it 'takes two to tango' where there are DLC conflicts.

 

The problem is more likely that no one knows yet how many there are dancing the tango.

It is not necessarily one product or the other, there may well be other factors and also

unforeseen combinations of factors at work.

I empathise with the frustration that you are feeling but at the same time, I have been able to

load at, fly from and change to and from KTIW and EGTB at will.

I have not seen one CTD and of course, that means that I am also unable to offer a solution,

despite a great deal of my own research.

 

Link to post
Share on other sites
1 hour ago, wain71 said:

as with XP because of the nature of so many free downloadable content there will be issues, some freeware devs are not as thorough as others and some don't update their products when the sim needs it to be done.....

Thanks to MSFS Addons Linker, luckily it's quite easy to take the freeware out of the equation.  It's the paid DLC that's more of a struggle for me. 

 

Thinks....  I suppose I could move all my paid DLC into the folder which I use for MSFS Addons Linker.  That would make it a bit easier to swap things in and out but the real obstacle is the MSFS load times themselves.

Edited by Majickthyse
Link to post
Share on other sites

I've just now noticed that starting a flight at or around Azurepoly's LFOU Cholet Le Pontreau is causing a CTD with a similar radius of effect to Tacoma Narrows. 

 

If anyone still experiencing the Tacoma Narrows CTD has LFOU as well, is it possible for you to give it a try and see if you have the same issue?

Edited by Majickthyse
Link to post
Share on other sites

I keep trying to get this to work but the issue is still happening for me. Anytime I load into Tacoma narrows or even the Seattle/NW Washington area I get a CTD. Removing the Orbx Tacoma Narrows lets me load into the SeaTac or other Washington airports fine. The issue persists even after removing everything from the community folder, so I’m not sure its conflicting with anything in particular. Just never seems to work for me after the holidays. I bought it from the Orbx desktop app (not the in game marketplace) around black Friday, and back before Christmas it worked just fine. I tried to find other people with this issue but they mentioned conflicts with airports I didn’t have like flightbeam Denver, the Seattle landmarks or Wycombe airpark. (I did actually have Wycombe air park but it was uninstalled at the time of the Tacoma CTD so its definitely not that either.) It must be something from the in Sim Marketplace but, again I don't have any of the suspects already mentioned and it would take a long time to sort though each marketplace download as my internet is not that fast.

Link to post
Share on other sites

I asked Azurepoly about the LFOU issue and this was their response:

 

'Aerial imagery might be the cause of all those conflicts. In fact, every imagery region of the planet has one single name but unfortunately, regions are way too large, causing multiple add ons to have the same imagery name and leading to CTD. '

 

However, as we know for a fact that Wycombe Air Park was at one time conflicting with Tacoma Narrows I strongly doubt they shared an aerial image file which spanned continental America and the Atlantic.

 

If you do want to troubleshoot it you could use MSFS Add-ons Linker to swap items out and then swap them back in afterwards to save any downloading.  However, as that has to be done before starting the sim you would still be facing several minutes loading time for each test.

Link to post
Share on other sites
11 minutes ago, Majickthyse said:

However, as we know for a fact that Wycombe Air Park was at one time conflicting with Tacoma Narrows I strongly doubt they shared an aerial image file which spanned continental America and the Atlantic.

 

I'm not sure it's the only conflict as I still get a CTD with Wycombe Air Park uninstalled.

Link to post
Share on other sites
3 minutes ago, Adrian Blandori said:

 

I'm not sure it's the only conflict as I still get a CTD with Wycombe Air Park uninstalled.

I agree.  It's not working for me either with WAP uninstalled.  But when we experimented in December it was the only conflict on our systems at that time.  So I don't think overlapping aerial image files is the cause.

Link to post
Share on other sites
On 1/23/2021 at 3:41 PM, EvidencePlz said:

@Majickthyse and @Adrian Blandori

 

Have you guys made sure that the folder for Wycombe is fully deleted from the Official folder after you uninstalled them through the in-sim marketplace (and in Adrian's case, the Orbx app) ?

Yeah, I just tried again and its fully deleted from the folder but still crashing. I may try removing more airports later.

  • Like 1
Link to post
Share on other sites
  • 2 weeks later...

I posted this response to the flight simulator forums in response to what amounts to the same issue  - reported in that case for LFOU, and later extended to other airports including Orbx airports.

 

https://forums.flightsimulator.com/t/ctds-caused-by-3rd-party-airports/339377/33

 

 

Ok, I figured this out.

 

This can happen with any add-on scenery, whether purchased from the Marketplace or downloaded from the interweb (e.g. flightsim.to) and added to your community folder.

 

And you can fix it yourself. It’s quite straight forward.

 

What’s happening is that sometimes scenery developers are leaving behind some of the default folder names as they are initially created in the template for a scenery project. Then later, when you have more than one of these scenery addons installed with default names there is a name clash on the folder itself, or more likely one of it’s contained files, that can cause your CTD.

 

If you look inside the LFOU addon folder, then the MaterialLibs folder you will find a folder called ‘mymaterials’. Here is the cause of the potential name clash.

 

C:\Users\USERNAME\AppData\Local\Packages\Microsoft.FlightSimulator_8wekyb3d8bbwe\LocalCache\Packages\Official\OneStore\azurpoly-airport-lfou-cholet\MaterialLibs\mymaterials

 

If you look at the same sub-folder in most other scenery addons you will see that this folder name has been changed to something unique for that airport.

To fix this - simply change the name of that folder to LFOUmaterials. I always use the ICAO code for the airport followed by ‘materials’. This is unlikely to result in a name clash since the ICAO codes are unique to an airport. (I know - teaching grandma to ■■■■ eggs - sorry  ).

 

C:\Users\USERNAME\AppData\Local\Packages\Microsoft.FlightSimulator_8wekyb3d8bbwe\LocalCache\Packages\Official\OneStore\azurpoly-airport-lfou-cholet\MaterialLibs\LFOUmaterials

 

Then, at the root folder for the addon scenery you will find a layout.json file. It’s a text file. You need to find and replace each instance of ‘mymaterials’ with ‘LFOUmaterials’ or whatever you called it.

 

C:\Users\USERNAME\AppData\Local\Packages\Microsoft.FlightSimulator_8wekyb3d8bbwe\LocalCache\Packages\Official\OneStore\azurpoly-airport-lfou-cholet\layout.json

 

I also recommend two tools to help you with this. You need a good text editor for the find and replace operation. There are many good free text editors. I use ‘VSCode’. I also recommend using ‘Agent Ransack’ to search for any files with the file/folder name your changing. With this tool you’ll have confidence that you changed all the files/folder names that needed changing.

 

I will raise an issue with MS on this issue. There should be some protection against default names that can cause a CTD - obviously.

 

ps - I also had the same issue with some superb scenery I downloaded from flightsim.to. It is the NZ Westport scenery (NZWS) by NZA. The same fix works for that scenery too. I informed those developers and they are going to provide an update with the fix.

 

pps - I ran Agent Ransack on my whole OneStore folder and found the same issue with an LFTZ I purchased, and again on my Community folder and found the same issue with a YMAV & LOWK I’ve added.

 

ppps - I raised the issue with MS. It’s ref #91930

Edited by Paul Wareing
  • Like 2
  • Upvote 1
  • Thanks 1
Link to post
Share on other sites

Eureka. Well done @Paul Wareing On my PC, Pilot Plus EGTB and Orbx KTIW were clashing and causing CTD. On 22nd Jan 2021 I downloaded an update for EGTB and the CTD issue was solved. Now I went into that folder you referred to and saw this:

 

image.thumb.png.550e1d921f2f5fa32062a537ebf8c59c.png

 

And in the layout.json file they did make the changes everything you mentioned. 

 

Thank you for sharing the workaround. Next time if the issue resurfaces I'll know what to do :D

Edited by EvidencePlz
Link to post
Share on other sites

You're welcome @EvidencePlz :)

 

MS recategorized my bug report as a Feature Request! :( I'm a little dumbfounded by that.

 

For now, I feel like I need to keep on top of this issue for scenery I install.  I went ahead an applied the workaround to all those sceneries that contain a 'mymaterials' folder.

 

If you leave any behind I guess you're opening up the possibility of a CTD each time you add another scenery.

  • Like 1
  • Thanks 1
Link to post
Share on other sites
  • 2 weeks later...

Thanks to Paul Waring, for this info, and Evidence Plz for sharing it. i had recently updated Airworthy Designs to v1.4 But it CTD'd every launch. After renaming the files as mentioned by Paul the issue has gone. crazy that some devs are putting stuff out like this, and annoying to hear MS are aware???

  • Like 1
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...