Jump to content

active Germany North/South Long Loading Times and OOM/CDT crash...


Recommended Posts

Hi Orbx team,

   First, thanks for developing such great products - I have most of your products, and truly enjoying them (the install base is over 300GB just for Orbx stuff :).

 

   Now, I've recently purchased Germany North and Sound packages (in addition to Global Base, Global Vector, and Global openLC Europe - in the same "region").  Installed, configured, etc.  I have latest-n-greatest HW to handle it - i9-10900K, 32GB RAM, M.2 1TB SDD and RTX3080 with 10GB VRAM, and I am running Windows 10Pro and P3D v5.1HF1.  The HW and OS and P3Dv5HF1 install are "brand new" - within past couple of weeks, from a clean slate, no legacy...

 

  When I try to start the sim at an airport within Germany North/South (e.g. EDDF or EDDM or EDDT), the sim loading takes over 20 mins to progress to the point of "~65% - Loading autogen", and once it starts to load autogen, it quickly progresses from using about 6GB or RAM to full 32GB (within 20 seconds), at which point it just CTDs... Disabling both North/South Germany add-ons returns it back to "normal" behavior - relatively quick load within 1 minute, 6GB or RAM in use, etc.  And I tried this both with default P3D airports (e.g. Hamburg in my case), as well as with more advanced add-ons, such as Mega Airport Frankfurt (P3D v5 version).

 

  My graphics settings are (almost all) maxed to the right, with the exception of Autogen density for radius, vegetation and buildings - these are set to just High.

 

Please advise how I can troubleshoot this.

 

P.S. I also have TrueEarth North and South California, as well as Central and South Great Britain.  No issues there with load times and memory usage.

Link to post
Share on other sites
14 minutes ago, alexmish said:

Bump, any response to the OP?

 

I would dare to say it is a limitation of P3D v5 and how it uses the Vas memory and directx12, if settings are high or products too demanding of resources it will easily crash.

 

I was not even able to start a flight in DD NYC with PMD and forget about enabling the "weather enhancement stuff" it will simply close.

 

For me it never worked, I had showers of issues, CTD, not able to access the video card, etc, etc, etc until I uninstalled it and kept V4.5 though I hardly launch it.

 

Set your settings to default and test if that allows you to fly and have a "descent" performance. If yes then you know what the issue is for sure because your system is really good.

 

Cheers

Carlos

 

 

 

  • Upvote 1
Link to post
Share on other sites

I get the sim running just fine in all other areas and settings.  I also have DD NYC, Seattle, Miami, etc - no issues there.

 

The issue with Germany South/North seems to be very specific to that particular scenery.  Lowering settings on the sim is not an option for me - all other Orbx packages work just fine with my existing settings.

Link to post
Share on other sites
On 12/21/2020 at 10:14 PM, alexmish said:

I have latest-n-greatest HW to handle it - i9-10900K, 32GB RAM, M.2 1TB SDD and RTX3080 with 10GB VRAM, and I am running Windows 10Pro and P3D v5.1HF1.  The HW and OS and P3Dv5HF1 install are "brand new" - within past couple of weeks, from a clean slate, no legacy...

 

  When I try to start the sim at an airport within Germany North/South (e.g. EDDF or EDDM or EDDT), the sim loading takes over 20 mins to progress to the point of "~65% - Loading autogen", and once it starts to load autogen, it quickly progresses from using about 6GB or RAM to full 32GB (within 20 seconds), at which point it just CTDs... Disabling both North/South Germany add-ons returns it back to "normal" behavior - relatively quick load within 1 minute, 6GB or RAM in use, etc.  And I tried this both with default P3D airports (e.g. Hamburg in my case), as well as with more advanced add-ons, such as Mega Airport Frankfurt (P3D v5 version). 

 

Hello,

firstly, the PC hardware has nothing to do with this problem.

It will occur regardless of the specifications.

 

In short, there are some things that P3D v5 does that other versions do not and one of them is to index every single Vector file.

It does not do this every time but it does do so the first time it starts if Vector has been added after having been disabled.

 

There is a simple rule, that the more scenery that is added, the longer P3D will take to start.

As an example, if I load every Orbx product at the same time, it does indeed take at least 20 minutes before I can fly.

My answer is not to do that.

 

I have here loaded at EDDF, with just EU Germany North and South.

There are no addon airports.

You can see that the product is performing as it should and it loaded from an ordinary HDD from "cold" in 1 minute, 25 seconds.

 

In this case, these are the settings.

 

7.jpg

 

You can see that the VRAM usage is not excessive

2k image, click on it to enlarge it

2020-12-23_16-52-49-678.jpg

 

Here is the same scene and the same settings but with EA active. You can see that as expected, more VRAM is in use but still not an excessive amount.

2k image, click on it to enlarge it

2020-12-23_17-1-22-602.jpg

 

Here is a "worst case" image, zoomed out and some weather

2k image, click on it to enlarge it

2020-12-23_17-15-38-879.jpg

 

I think that your answer is probably to manage your scenery carefully and load only that which you require for the flight that you intend to make.

 

 

  • Like 1
Link to post
Share on other sites

Hi Nick, thank you for the response. 

 

First of all, my issue with memory is running out of regular RAM, not VRAM... And the RAM usage stays within normal range until P3D gets to the point of loading Autogen - the regular RAM usage goes from 6GB to 32GB (my max memory) within 20 seconds, and then sim crashes.  So there must be ALSO something in the autogen specifications of these Germany scenery packs that causes this behavior.  Once I disable North or South Germany (so at that point it is just regular P3D + Orbx openLC Europe in that particular area + the rest of my addons), the load time is fine and autogen does not cause OOM condition.  Also, with North and South Germany enabled, if I load the sim at another country (e.g. UK or US), the start up time is OK, and there is no excessive memory usage.  So I don't think it is indexing, IMHO...

 

Also, I have over 120 various scenery add ons installed... Most of the Orbx scenery packs and large airports, plus over 90 other non-Orbx but hifi airports.  I also have TrueEarth for US West Coast and UK North/South - much larger size-wise packages.... With all of these (but No/So Germany still turned off), which account to ~500GB of scenery files, my load time is about 1.5 minutes... IT IS ONLY WHEN I TURN ON North and South Germany, that I have excessive load time and OOM crash (and I suspect because of the crash, the index does not get saved or something like that, so subsequent start ups are still very long).

 

I don't have any antivirus software installed... Windows Defender is off too, as this is my sim-only computer.  For the reference, I have a physical 737 cockpit build with ProSim737 and many other hardware pieces, as well as multiple PCs to support all of that... So I am not just a random gamer with a PC + Joystick.  See the pic.

 

So "manage your scenery carefully" is not something that I was looking to do... I already have too many packages even without Germany, and I doubt adding these 2 could result in such a drastic behavior. If these sceneries are just not ready for prime time, I'll just ask for refund...

 

P.S. I am happy on jump on a zoom call with Orbx support to troubleshoot/explore other paths... If that is an option.  I am in US/Eastern time zone.

Version 5-1.jpeg

Edited by alexmish
Link to post
Share on other sites

Hello,

could you perhaps try using just the Orbx EU Germany North and South and the Orbx Libraries and see

whether that on its own results in your sudden use of all your RAM and of course the 20 minute loading time?

Orbx Germany for P3D is not a new or experimental product and certainly does not routinely cause this kind of problem.

The indexing problem is, as far as I am aware, only with Vector and it is of course not needed inside Orbx Regions.

Link to post
Share on other sites

Hello,

whether you have installed your products inside the simulator, or outside in an Orbx Central Library,

the easiest and entirely reversible way is to simply untick everything else, in either the scenery library or

the add-ons list respectively.

 

There are two freeware programs that make this even easier but I guess that you may already be familiar with them.

For the record, sitting on the ground at default EDDF in the DDW C-47, P3D v5 on my system is using 6166 GB of system RAM.

Flying with EA active and Orbx 7 weather, this rises to around 6600 GB.

Link to post
Share on other sites

Hi Nick, I've narrowed it down to conflict with Orbx openLC Europe.  When I disabled openLC EU, and enabled either or both North and South Germany, the load times are normal (full load sequence is about 2.5 minutes first time) and there are no issues with OOM conditions.  The moment I've turned the openLC EU "on" (with either North or South Germany still turned on), I got veeeeeery long load time (I had to kill at at 17% as it wasn't moving for 10 mins, even though CPU was 100% utilization, although 0% for the disk utilization!).

 

So there you go, it is something between openLC EU and these Germany packs.  As they overlap the same map area, I wonder if there are compat issues.

 

I also have Mega Airport Frankfurt, enabling or disabling it made no difference to the above experiment.

 

Next Steps?

 

  • Like 1
Link to post
Share on other sites
  • 4 weeks later...
On 12/23/2020 at 3:47 PM, alexmish said:

Hi Nick, I've narrowed it down to conflict with Orbx openLC Europe.  When I disabled openLC EU, and enabled either or both North and South Germany, the load times are normal (full load sequence is about 2.5 minutes first time) and there are no issues with OOM conditions.  The moment I've turned the openLC EU "on" (with either North or South Germany still turned on), I got veeeeeery long load time (I had to kill at at 17% as it wasn't moving for 10 mins, even though CPU was 100% utilization, although 0% for the disk utilization!).

 

So there you go, it is something between openLC EU and these Germany packs.  As they overlap the same map area, I wonder if there are compat issues.

 

I also have Mega Airport Frankfurt, enabling or disabling it made no difference to the above experiment.

 

Next Steps?

 

remove EDDF bgls in Orbx Germany South and all other addon airports with scenery

uncheck bathemetry p3d option

Link to post
Share on other sites
On 1/17/2021 at 6:08 AM, Schleckinspektor said:

I have the same issue like @alexmish. Would be good to have a solution provided by Orbx.

 

Right now OpenLC and Germany South/North can not be used together.

same to you read my above post. disable files for addon airports and unhceck bathemetry

Link to post
Share on other sites

Hi B77X,

 

thanks for your tip. I deactivated all files that are related to addon sceneries in that area. Bathymetry is off. I still have excessive loading times ("Loading terrain data") and P3D crashs at around 70% (when loading EDDF).

 

Any further ideas?

 

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...