Jump to content

answered Latest W10 Cumulative Update (might have borked my W10 (MSFS aware) link....


Recommended Posts

Well...as I'm typing this, I am once more, having to totally re-install MSFS!   Last night...I clicked on the START icon...and the simulator fired up.  This morning, there was a H20 Cumulative Update....and after that, I wanted to run MSFS, and got the BLUE BOX, stating that my MSFS installation can't be found. This is the second time in three weeks that this has now occurred.  On the app, you can try the REPAIR, but it did absolutely nothing.  The only recourse again, for the second time was to RESET the ICON, which will cause you to have to totally re-install.  

 

I really enjoy MSFS, but honestly,  I have never seen such problems as this product produces....and has me chanting blessings,  each time that I try to run it.   When now, is the next time, that the program's loader can't find the installation that is there...I have a Desktop Short Cut to the Community Folder, and can click on that, and the folder opens right up. I can go to my hard drive that has the entire install and view it...

 

For whatever reason...and how Microsoft ensnares this product with Digital Rights,  but it seems at least to me...that with any update of W10 itself...cumulative patches...feature patches,  whatever...this is the second time now, that the start icon, 'cant' see' or locate the MSFS installation on my system.  So...another hour or more, to download again.  Twice...

 

Every other  flight sim installation, that I have...can be run...and does run.  ONLY MSFS has this start-disconnect.   If it happens to me a third time...I guess I will have to make the decision whether I wish to yet again,  go through this MSFS user-circus.  Probably not, though.  I'll let it slide...come back to it in a year...hopefully M.S. their digital rights...their one-after-another patch to this Early Access sim, will get their act FINALLY together,....and until then, go back to P3D and XP,  that you install once...you can update....and run....every time you click on the program's Icon, month after month, year after year.  Yeah...I am so now very bummed out.   I will now say, I very much like MSFS,   ***IF*** it will start.  That about sums it up....

Edited by Orbx Flyer
  • Sad 1
Link to post
Share on other sites

I am having the same problem.  What a joke.  But definitely not funny.

 

Mine sits there for 10 minutes doing nothing then tells me I have to insert the disc.  Tried the fixes on various forums but nothing works.

  • Sad 1
Link to post
Share on other sites
8 minutes ago, John Dow said:

I am having the same problem.  What a joke.  But definitely not funny.

Yep...pretty downhearted right now...am re-installing in the background.  Just to know...before I started my now 2nd full install, I clicked on P3D 5.1,  XP11.x, AF2, FX10 Steam....and every one, fired right up.  So...did today's 10 Cumulative Update,  wreck the link?  It was the only thing that changed in my W10 since last night. Right after it updated, and had to re-start...right after that....I tried to run MSFS...and BORK....the sound's of crickets...

 

Is the M.S. Digital Rights,  so wonky that it will consider any change to W10, as a run failure?!?!?

 

If it happens again...MSFS is not worth the constant PIA episodes between patches and Blue Boxes of Death.  Not ranting...just saying...one reaches a point personally that it is no longer worth it to them to try and run a piece of software with so many unstable elements, let alone, just trying to GET IT to start up.  I'll let it rest...come back to it (if a third install must be enacted to run it...), around 12 months...and reinstall,  to see what they have done with the stability of the running of the program, as well as the features at that time.  This will be the last install on my part...until perhaps a year or more passes.   P3D 5.1 and or 6.0 is really looking good, lol!  Hope you fare better, after you re-install!

Edited by Orbx Flyer
  • Sad 1
Link to post
Share on other sites

I'll be reinstalling later, I just uninstalled.  Then there's the problem of the constant resetting of download files during installation.

 

Unfortunately I can't just forget about it, beta testing waits for no man!

  • Sad 1
Link to post
Share on other sites
2 minutes ago, John Dow said:

I'll be reinstalling later, I just uninstalled.  Then there's the problem of the constant resetting of download files during installation.

 

Unfortunately I can't just forget about it, beta testing waits for no man!

The only good news at my end...is I started my re-install about 10 minutes or so ago, and I already have 23 GB's of the 97 installed.  Then...I'll have about 5 minutes in the Content section to download all my Premium Deluxe.  They need to better create a NORMAL start icon...that can find the *#((@   install!   This sucks...:(  x's 2!

Link to post
Share on other sites

Up until yesterday I had zero issues with any updates , well that all changed with the latest patch . It wanted my disk , I had made sure before hand that my community folder

was empty and my FS cache was empty . Still no luck , it wanted that darn disk ...... so I did a reinstall and everything is fine now .

 

Cheers

John

Link to post
Share on other sites

@John Dow @BradB @Orbx Flyer Do you have any of your MSFS on C drive? By that I mean including Windows Apps etc not just MSFS.

Also what versions of MSFS have you got? Disk, X-Box GamePass, MS Store, Basic, Premium?

I too have never had any issue at all with either a Windows update causing a problem with any of my 2 sims of XP and MSFS, nor any sim update. I have no  part of either of those sims on my C drive. C drive is left alone to just have my OS (Windows 10) and a couple of utility programmes. I even moved my Program Files to another drive so that if anything untoward happens to the most vulnerable drive, C drive, then all is not lost or affected. C drive is prone to update problems, virus etc and should be used purely as an OS drive as far as possible. I am not inferring that any of you 3 have your installations on C drive, but just giving a general piece of advice.

  • Upvote 2
Link to post
Share on other sites

Much the same, MSFS on 4TB HDD, C Drive only for W10 and programs that insist on installing there. The problem as far as I can tell is there is no redundancy or self diagnosis built into downloads and updates. One little file either in the official store file or in the digital ownership, or a dropped bit of code in the user account, and it just sits there not knowing how to proceed or repair. 

 

I'm sure they will have to develop some sort of restore point or diagnostic tool that looks for corrupted files and repair as required. This business of a complete uninstall and reinstall  because one little file in a 1.4GB update was somehow corrupted is not an acceptable software design. 

 

Personally I can't understand why they think the dynamic download decompress and install method is the right way to go, when the proven model that Orbx uses which uses a large download file that is completely downloaded before the install routine runs (mostly) has been proven to be so reliable.

 

I also didn't realise all the community folder entries were deleted when I clicked on the reset option trying to repair. Had I known I'd have tried to back it up somehow, now I have to reinstall all the airports! 

  • Like 1
Link to post
Share on other sites

If your MSFS icon no longer works, you can try this first. In Windows start menu, go to Microsoft Store. Click on ... (in the top right corner) and choose My Library. Look for Microsoft Flight Simulator. Here you can start the program.

Henk

  • Upvote 1
Link to post
Share on other sites

Thanks everyone for your insights and suggestions.   The plot thickens....I just fired up a full clean install, and I just got a CHECK FOR UPDATE..and a new update...coming in at 10.18 GB's...loading in right now...so something new is happening.  The latest update was around 1.14 GB's if I remember...this is ten times that size...over 37 files...

 

Later...

Link to post
Share on other sites
8 hours ago, Jon Clarke said:

@John Dow @BradB @Orbx Flyer Do you have any of your MSFS on C drive? By that I mean including Windows Apps etc not just MSFS.

Also what versions of MSFS have you got? Disk, X-Box GamePass, MS Store, Basic, Premium?

I too have never had any issue at all with either a Windows update causing a problem with any of my 2 sims of XP and MSFS, nor any sim update. I have no  part of either of those sims on my C drive. C drive is left alone to just have my OS (Windows 10) and a couple of utility programmes. I even moved my Program Files to another drive so that if anything untoward happens to the most vulnerable drive, C drive, then all is not lost or affected. C drive is prone to update problems, virus etc and should be used purely as an OS drive as far as possible. I am not inferring that any of you 3 have your installations on C drive, but just giving a general piece of advice.

Thanks for the advice Jon , if this happens again I will move MSFS off my C drive (SSD) to another drive , I have a total of four . MY version is Premium MS store also .

 

John

Link to post
Share on other sites
14 hours ago, Jon Clarke said:

@John Dow @BradB @Orbx Flyer Do you have any of your MSFS on C drive? By that I mean including Windows Apps etc not just MSFS.

Also what versions of MSFS have you got? Disk, X-Box GamePass, MS Store, Basic, Premium?

I too have never had any issue at all with either a Windows update causing a problem with any of my 2 sims of XP and MSFS, nor any sim update. I have no  part of either of those sims on my C drive. C drive is left alone to just have my OS (Windows 10) and a couple of utility programmes. I even moved my Program Files to another drive so that if anything untoward happens to the most vulnerable drive, C drive, then all is not lost or affected. C drive is prone to update problems, virus etc and should be used purely as an OS drive as far as possible. I am not inferring that any of you 3 have your installations on C drive, but just giving a general piece of advice.

 

I also have my sims in another disk not C, a 6 Teras one, which I just noticed is 2.85 TB left :o

Link to post
Share on other sites
23 hours ago, HeKa48 said:

If your MSFS icon no longer works, you can try this first. In Windows start menu, go to Microsoft Store. Click on ... (in the top right corner) and choose My Library. Look for Microsoft Flight Simulator. Here you can start the program.

Henk

Thankyou, Henk...I'll try that if it borks again!

Link to post
Share on other sites
On 11/12/2020 at 3:36 AM, Jon Clarke said:

@John Dow @BradB @Orbx Flyer Do you have any of your MSFS on C drive? By that I mean including Windows Apps etc not just MSFS.

Also what versions of MSFS have you got? Disk, X-Box GamePass, MS Store, Basic, Premium?

I too have never had any issue at all with either a Windows update causing a problem with any of my 2 sims of XP and MSFS, nor any sim update. I have no  part of either of those sims on my C drive. C drive is left alone to just have my OS (Windows 10) and a couple of utility programmes. I even moved my Program Files to another drive so that if anything untoward happens to the most vulnerable drive, C drive, then all is not lost or affected. C drive is prone to update problems, virus etc and should be used purely as an OS drive as far as possible. I am not inferring that any of you 3 have your installations on C drive, but just giving a general piece of advice.

Hi Jon,   have always had since RTM, the entire installation on another drive other than System C:   Thanks for your 'look outs'. :)

Link to post
Share on other sites

Interesting, yesterday morning....

 

so...I started my 2nd time 97 GB full install.  It did that...and then I had to install all my Content, which was 37 GB...and THEN...I had to install the 1.14 latest patch.

 

Then...when running it again, for the second time...and it CHECKED UPDATES...another patch...which was 10.18 GB's over 35 files...downloaded and installed.   I wonder if in downloading the full install, it triggered a not-supposed-to-be-out-in-the-wild   patch of that 10.18 GB!?!??!    Dunno...but it downloaded off of the MS servers...

 

 

Link to post
Share on other sites
7 hours ago, Smudger said:

If you are able Brad, I have been trying since before the latest updates to MSFS and Win10. No Google help in a solution :(

Move MSFS.jpg

When I did the reinstall it gave me a option to choose a drive , what I know now , I would have moved it off of the C drive .......

 

John

Link to post
Share on other sites
3 hours ago, BradB said:

When I did the reinstall it gave me a option to choose a drive , what I know now , I would have moved it off of the C drive .......

 

John

When I installed for the 2nd time...I also got the choice of my listed drives. I re(2)installed again to the drive I did the original RTM.   Also...wanted to mention, that whatever that added 10.18 GB download was....has really notched up the performance--->. Ultra Setting visuals and FPS!

 

I had three (3) downloads the one required content, then the latest 1.14 GB patch #6, and then this out-of-nowhere 10.18 GB update, on my second run of the 2nd install.  Did you see that 10.18 GB 2nd patch as well?  Just before you might say that that was my premium deluxe, nope...got that with the main body 97 GB's..but had to download that 37 GB's through the CONTENT folder.  This 10.18 GB's is totally separate from any of that....and my 2nd full install MSFS is RUNNING KILLER!  I don't have one complaint about the looks...or FPS (for my system) performance.  None...   Just the other stuff now...planes, systems, instruments,  just that....but the look/visuals at full Ultra (the only added tweak/personal is having turned off HDR10 (as my monitor does not support it native), and the running of it....not any more!!!! :)

Edited by Orbx Flyer
  • Like 1
Link to post
Share on other sites

Between this, my 2nd forced full install,  I am having the best post RTM experience in total with my present set up.  The 'wow' factor is back!

 

If you set up your nVidia driver to exactly as this chap recommends...the FORCE will be with you, Luke....

 

 

  • Upvote 1
Link to post
Share on other sites
16 hours ago, BradB said:

what I know now , I would have moved it off of the C drive

Hello Brad

Finally sorted, it certainly is a cantankerous piece of software, running amok on updates etc.

After a week of trying Permissions, Security, sweet talking etc, it turns out it did not want to reside on a brand new G: SSD.

I created a V: partition on my old 6TB Hard Drive and it was more than happy to slum it there :rolleyes:

The new SSD will not go to waste, roll on P3Dv6 :)

Flight2020 V.jpg

Edited by Smudger
  • Upvote 1
Link to post
Share on other sites

Well, the present  'word' is that I again, have MSFS running like a top, on my current i-7 975 Extreme (four core)/EVGA FTW GTX 1070 (8GB)/12 GB's System RAM/Alienware 11B BIOS/ (over-clock RAM, over-clock CPU, CPU running in (8 core HyperThread)

 

Running MSFS at full default Ultra, but with HDR10 set to '0' (turned off) in the User.cfg and with the above suggested set-up of the nVidia driver mask, am getting a very good (on average) FPS readout of 32-35, with no FPS limiting. That's about the top end FPS performance for my mentioned system, but you only need to maintain 30 fps to keep all the reading bars in the GREEN ZONE.   Smooth animation, a little pause sometimes, only because my system can only have 12 GB's of total RAM, and occasionally, I will get a total pause in action,  the memory loads up forward of my flight path, and away I go again, for 1/2 hour or more, before my limited RAM needs to take another 'sip'.  Nothing to spoil my immersion...***especially*** as I have MSFS running under full Ultra, (nothing diminished in any category).  Good enough, to not need to upgrade either my present CPU, GPU, or O.E.M. motherboard.   P3D 5.1 full right, is giving me 48-65 on average sustained FPS, so no problem on that platform. Same pretty much for XP11.

 

Now, if I can ONLY keep that dang start icon connected to the program folder....all will be good.  But as for the running and visuals of MSFS now....THUMB'S UP! :)

Edited by Orbx Flyer
  • Like 1
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...