Jump to content

ORBXLIBS latest version at YWVA...


Recommended Posts

When at Warnervale (Version 1.2 SP3, just bought it earlier this afternoon) with the latest ORBXLIBS installed (100421), my FPS drop by 15-20 not to 15-20, but from 30ish to around 10-15......

If I install the previous ORBXLIBS package (091028), everything is fine again...

Anyone else got the same experience?

FYI: I have removed the Ant Aussie Airports package currently, and removed the scenery library entries, as they were conflicting of course...

Andrew

Link to post
Share on other sites

Current tests indicate that Warnervale is certainly affected negatively by 100421 on my system... reverting back to 091028 improves the FPS stability and smoothness, oddly enough... YCDR does not seem to be affected, though I want to test YCDR with 091028 again...

I need to hit the sack for some serious shuteye right now, so I am defragging the system overnight, and will have a look at the performance of the defragged FSX/FTX tomorrow if I get the chance.

With AAA Warnervale out of the way so to speak, it is certainly not that, and I reinstalled Warnervale and tried the two different ORBXLIBS under the same settings and daytime conditions, within minutes of each other. Reverting back to 091028 always led to a settling and stabilizing of FPS, be it witht the "frame rate limiter" running, set at 30, or 30 set in FSX internally.

Andrew

Link to post
Share on other sites

100421 only affects the industrial buildings S of YWVA near the racecourse. None of the files at the airport itself have been altered, that will come when YWVA gets its own TextureFlow update later.

Link to post
Share on other sites

Well, I just flew every one of my AU airports today in order to check on a problem I'm having with YCSH, and I have to say that Warnervale was indeed quite sluggish for me.  It was the only one.  I didn't revert to the old library to test it, but it does appear that the new library has slowed things down at YWVA.

However, as I said, I just flew ALL of my airports, and Caloundra and Tamworth with texture flow were just incredible.  MUCH smoother and faster than all the others.  I didn't do a FPS comparison, and sometimes I think the focus on those little numbers can be distracting, but I can tell you from direct comparison at ALL the airports that the texture flow treatment of those two airports makes an incredible difference in the experience.  They REALLY stood out as being the smoothest to fly.

Link to post
Share on other sites

Yeah, I don't think it's the trees.  I have AG at Dense, and I don't have a problem in PNW, and it's got lots of trees.  Also, I don't have a problem once I get away from YWVA, where there are just as many trees I think. And it wasn't slow before.  I'll reinstall the old libraries and see if it makes a difference.

EDIT:  Okay, did that.  It's definitely the libraries.  Here are some shots with the old libraries.  Flight with these was smooth and mostly pegged at my 30FPS limited (although FPS Limiter lets it run up in the high 30s).  It was never lower than 25 and was smooth while moving views with TrackIR.

Posted Image

Posted Image

Here are shots with the new libraries.  FPS varied from low 30s to as low as low teens.  It was all over the place.  And there was a lot of stuttering, both of motion, and of view with TrackIR. 

Posted Image

Posted Image

Posted Image

I didn't see anything like this slowdown at the other airports today, but I wasn't looking for it either. 

Link to post
Share on other sites

I too mentioned in a previous thread that I cannot operate with the new LIBS version, and that it had the same effect on my system as the version that was issued and then withdrawn. If I use the 091028 version everywhere in FTX is fine and only subject to fine tuning dependent on the complexity of the departure/arrival airport.

  I only noticed the problem after installing YBBN which I believe included the latest LIBS update. I came to a grinding halt at YPEC with my normal settings, left my settings untouched but installed 091028 and was immediately back to freeflowing non stuttering etc.

I have been timid in furthering my inquiries into whether or not there is a problem with the new LIBS as I see many responses indicate lots of people have no problem, but seeing this thread has reinforced my desire to find out if there is a problem as there are more people making a query and sharing my problem.

There is definitely something in the new LIBS that adversely affects MY system but obviously not everyones.

Link to post
Share on other sites

Hmmm, it's no good that the new libs are causing issues. We'll investigate it internally and try to reproduce the issues. To be honest, there's not a lot of TextureFlow applied to the libraries so if it affects too many people we'll just revert to only adding TF to the airports themselves and not the libs.

In the meantime, just revert to to 091028 libs which work better for you guys with issues ok?

Link to post
Share on other sites

I am working my way through the bgls here to see if I can find one that causes a sudden drop in performance...

I installed the libraries into 2 separate dated directories, and only one is active at any time... FSX is better than FS9 here at allowing me to change a bgl to off then reload the scenery library... makes the debug a lot quicker than it used to be in FS9 days...

I'll post any results, whatever they may be...

I am trying to do this as "scientifically" as possible, by keeping the default plane, VC view, same time of day and so on... no changes in parameters...

Andrew

Link to post
Share on other sites

I do believe I have tracked down a potential candidate...

By renaming all bgls in FTXAA_ORBXLIBS to .off, then one by one renaming back to .bgl and then reloading the scenery library while at Warnervale GA parking 1, looking towards the terminal, I found that

ORBX_vehicle_library_2009.bgl

led to a ca. 50% reduction in averaged FPS... with a fixed FPS of 30...

Hope this might be of help... only took an hour or so... :)

Andrew

Link to post
Share on other sites

Hello Andrew

You are right.Switching  ORBX_vehicle_library_2009.bgl  to off brought back some FPS and less stutters.

Nevertheless,to revert to to 091028 libs is perhaps the best decision.

Link to post
Share on other sites

As I wrote, I spent the better part of two hours this morning going through the bgls in the new LIBS, reactivating each one in succession. On reactivation of the ORBX_vehicle_library_2009.bgl, FPS halved...

I deactivated the BGL, and was back to the set 30 FPS on average.

I then continued activating the BGLs until I reached the bottom of the list, with only the ORBX_vehicle_library_2009.bgl remaining inactive. I had all the bgls save ORBX_vehicle_library_2009.bgl active, and the FPS was unchanged in YWVA, reactivating that one bgl halved the FPS, to around 15-16 on average...

I didn't notice any issues at YCDR, the only other place I got around to looking at with the new LIBS in place.

A quick question: What is the ORBX_vehicle_library_2009.bgl actually for? I have no road traffic at all running, as I don't really need it, (the road is fine to follow) and traffic being the hit on FPS it is, I prefer to crank up an aviation related parameter at its expense. Could it be the fact that I have NO road traffic that is causing the performance hit? (the library being loaded but no actual cars being generated?)

Though I do not know what the file actually does, not being one of the developers...

Andrew

Link to post
Share on other sites

This is good detective work.  I don't think it's the fact you use no traffic, though, as I use the recommended 16% traffic and have the same issues. 

I'll reinstall the new libraries and deactivate that bgl and see what happens on my system as well.

EDIT:  Good detective work, indeed.  I reinstalled the new texture flow libraries and deactivated this one bgl and flew the pattern at YWVA and it was smooth as silk again.  I'm really curious to learn what's in this bgl, but it does indeed appear to be the offending code.  Perhaps the fact that others haven't experienced trouble with the new libraries is that Warnervale isn't as common an airport for flying.  I like it (that narrow runway sure trains you to find the centerline!), but I do tend to fly others a lot more, and I haven't seen any issues at any others.  It's curious why this bgl affects YWVA but not other airports. 

And, as I said above, the new texture flow airports, YCDR and YSTW, are just great!  Very nice improvement in smoothness and speed for me.

Link to post
Share on other sites

Hi all

Can't offer any technical help as my brain is getting old, but I also had trouble with stuttering as I flew from Aeropelican to Warnervale after installing Brisbane (great airport by the way).  Reinstalled 091028 and stutters gone, BUT then had texture lag and some black squares at Brisbane. Again reinstalled 100421 and Brisbane great, but Warnervale very stuttery.  Might try turning the .bgl off if I can find out how to do it!

Pete

Link to post
Share on other sites

Great work Andrew! You don't want to join our testing team do you? ;)

The best interim solution would be to copy over the old ORBX_vehicle_library_20009.bgl from the older 091028 Orbxlibs until I can issue a new official version.

The library is used to display all the static cars in our sceneries. It does not affect YBBN since Russ made a new even lower polygon car library specific to that airport.

Link to post
Share on other sites

Just letting you know that I have also had the same problem with FPS being cut in half at Aeropelican with the new 100421 libraries but replacing the ORBX_vehicle_library_2009.bgl with the older one from the 091028 libraries did fix the problem.

Link to post
Share on other sites

Well that did it for me.... thanks alehead !! Loaded the new LIBS, removed the suggested file and replaced with the file from 091028 and I am back to flying smooth. Great detective work and certainly appreciated by me. I think the work you did enhances the relationship between user and developer,  a feature particularly evident on this great "community" site.

Link to post
Share on other sites

Great work Andrew! You don't want to join our testing team do you? ;)...

If that is a serious offer John, I would love to take you up on that :)

@Pete and JJaycee1: Guys, you are welcome. I am really glad to be able to give something back to a community that has given so much to me in time and help! JJaycee, I agree totally with you about this. With a development team as forthcoming and open as the FTX team is, matched with their creative skills and talent, being able to contribute even in a small way is a real pleasure...

Andrew

Link to post
Share on other sites
  • 2 weeks later...

Wow!!! What a fantastic find!!! I thought it was just me and my system that was the problem with stutters.Great work Andrew!!

Question? Where can I find the old library file 091028 ? Also what is the path to find ORBX_vehicle_library_2009.bgl?

Thank You very much for any help.

Cheers!

Link to post
Share on other sites

OK,I found the file but after I renamed it FSX gave me an Error message and wouldn't start,I removed the file completely and FSX started with no trouble,this could be related to Vista64.

My Frames have now doubled and stutters are gone!!! I'd love to get the old file as I'm sure I'm missing out on some scenery.But I'm very happy with my Performance and FTX experience is back to what it should be!

Thanks!

Link to post
Share on other sites

The way I did it was to re-install the old library, and then go into FSX/ORBX/FTX_AU/FTXAA_ORBXLIBS/Scenery and grab the ORBX_vehicle_library_2009.bgl file and move it somewhere safe.  Then re-install the new library.  Then copy and past the old vehicle library file over the new one.  You'll be good to go then.  Anytime you have to reinstall the libraries (as you do after each new addition) then recopy the vehicle library again. 

Link to post
Share on other sites

Thank You Griphos,Unfortunately for me I don't have the Old library file and don't see where I can download it.

Thanks very much for your help

Cheers! :)

Link to post
Share on other sites

Welcome!

I enjoyed hunting it down... Glad so many have had an interim solution to keep us all flying at our favourite locations!

And glad I was able to help a little with looking to find a solution to the loss of performance I and a few others had noticed...

:)

Andrew

Link to post
Share on other sites
  • 1 month later...

Hi,

I've been back to the YPEC and YWVA area to test the latest ORBX Libs 100630 and can report that I'm no longer experiencing the severe FPS hits and CTD's as detailed above.

(No longer need to use the ORBX_vehicle_library_2009.bgl file from 091028 to stay aloft.)

I have made some small tweaks to reduce my scenery complexity since my problems in this area, but I suspect ORBX must have changed something to solve this problem.

Thanks ORBX, much appreciated, Ian

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...