Jump to content

Recommended Posts

Hi all,

   I personally have had no problems at all with BUR either arriving or departing. But I have been following the thread in case I come up with any ideas that might possibly be of any value. I should note, being that I have had no difficulties, that I have been flying to and from BUR almost exclusively with analog instrumented aircraft, not glass panel aircraft. That really got me thinking when I read THIS THREAD over at the Microsoft flightsimulator Community / General Discussion forum . They have a discussion going on about glass panel aircraft specifically dropping from high FPS to single digit FPS. Being that I am not using glass around BUR, and have not had issues, perhaps there may be something being discussed there that may be of help for you.

 

In case the link above doesn't work ...  https://forums.flightsimulator.com/t/fix-for-sudden-fps-drop-from-40-50-down-to-single-digits-fps/285129

Link to post
Share on other sites
  • Replies 114
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Hello, just for information, work continues behind the scenes towards a solution to this problem. Please be patient. Thanks.

Hello, there is a long internal conversation going on between developers and staff and several possible solutions have been proposed and some tested. However, there is not yet a working fix.

For the first time ever I've uninstalled an Orbx product.  I hope the KBUR performance issue is actually acknowledged at some point and isn't brushed off.  For now I'll just be a bit more careful rush

Posted Images

I fly exclusively GA airplanes and most specifically the C-172 steam gauge version, the relative drastic FPS reduction as compared to other parts of the world including other Orbx airports is about the same whether it's a steam gauge airplane or a glass panel aircraft, at least for me anyways.

Link to post
Share on other sites

One of the difficulties in all this KBUR issue is that it could be a combination of PC specs, other addons, plane being flown, time of day, MSFS settings, installed driver version, MSFS version i.e Steam, GamePass or Microsoft Store plus other combinations. It is also very evident that it is not being experienced by ALL customers.

 For those who are experiencing this issue your patience and understanding is greatly appreciated.

  • Like 1
  • Thanks 1
Link to post
Share on other sites

As soon as I read your post I tried KBUR. All seemed OK until I was on mt take off and as I approached the number 8 on the runway marking it tanked to 9 fps. I pursued and after I had gained a bit of height and not looking at the airport but straight in front of me the fps jumped to 40+. All this was in external spot view. I use that view as it is the one that has most of the scenery in view rather than a restricted fishbowl view from inside the cockpit. This is for test purposes.

My settings were Ultra 4K as determined by MSFS.

I then lowered my settings to High End and did not get the drop to 9 fps but it was not a fresh loaded flight just a change in settings once on the ground.

So I would hesitate from my perspective to say that the issue was resolved. The reason being I have had spotless flights from KBUR and also badly affected flights from KBUR. it is the random nature of the problem that is so difficult to find the cause of the sudden fps drop in many peoples experience.

@Matteo Veneziani for info.

 

Link to post
Share on other sites

After the updating of 1.9.30, I tried KBUR and found that it looks OK when you fly out from KBUR, but the FPS drops to single digit when you fly into the airport. Another observation is that if you change the weather during fly out from the airport, the FPS drops to 5. So I think the problem is still there without any improvement on the new update.

Link to post
Share on other sites
3 hours ago, Steve Li said:

After the updating of 1.9.30, I tried KBUR and found that it looks OK when you fly out from KBUR, but the FPS drops to single digit when you fly into the airport. Another observation is that if you change the weather during fly out from the airport, the FPS drops to 5. So I think the problem is still there without any improvement on the new update.

That's what I find every time I try it.

KBUR is INOP till a fix.

Link to post
Share on other sites
11 hours ago, Jon Clarke said:

As soon as I read your post I tried KBUR. All seemed OK until I was on mt take off and as I approached the number 8 on the runway marking it tanked to 9 fps. I pursued and after I had gained a bit of height and not looking at the airport but straight in front of me the fps jumped to 40+. All this was in external spot view. I use that view as it is the one that has most of the scenery in view rather than a restricted fishbowl view from inside the cockpit. This is for test purposes.

My settings were Ultra 4K as determined by MSFS.

I then lowered my settings to High End and did not get the drop to 9 fps but it was not a fresh loaded flight just a change in settings once on the ground.

So I would hesitate from my perspective to say that the issue was resolved. The reason being I have had spotless flights from KBUR and also badly affected flights from KBUR. it is the random nature of the problem that is so difficult to find the cause of the sudden fps drop in many peoples experience.

@Matteo Veneziani for info.

 

 

Hi Jon, my experience is now much like yours, it feels like it's some set of specific model/textures at the airport (I'm a programmer not a artist guy) and it's orientation and relation to other objects or something as well as how you are observing the airport.  if I scanned in drone mode I could find places where my FPS was super smoothe and others like you where it dropped down to single digit FPS.  I'm not smart enough about art to know what specifically but I did find specific situations of looking at the airport where FPS was consistent to other airports and other scenarios where it was significantly lower (single digit FPS).

 

I'm glad you guys are still investigating so once you guys find it, it can be avoided in future products.

Link to post
Share on other sites

This continues to be an ongoing issue as I still have very low (usually single-digit) FPS when approaching KBUR (especially from RWY 8). See attached photo. I have a new, 2020 Alienware PC, 32gb ram, 10700K, RTX 2060S and latest NVIDIA driver. With the latest patches I normally get around 40-45 FPS, but at KBUR it always drops. If I uninstall the product I have no issue. Screenshot attached was too big to upload to screenshot of a screenshot. 

 

 

Screenshot (616).png

Edited by PilotGH
Link to post
Share on other sites
1 minute ago, PilotGH said:

This continues to be an ongoing issue as I still have very low (usually single-digit) FPS when approaching KBUR (especially from RWY 8). See attached photo. I have a new, 2020 Alienware PC, 32gb ram, 10700K, RTX 2060S and latest NVIDIA driver. With the latest patches I normally get around 40-45 FPS, but at KBUR it always drops. If I uninstall the product I have no issue. Screenshot attached was too big to upload to screenshot of a screenshot. 

 

 

Screenshot (616).png

 

Link to post
Share on other sites

the strangest thing happened for me with MFS Orbx KBUR,

 

was having serious stutters - unusable,

 

applied latest MFS patch - then activated the Japan update from MFS Marketplace,

 

of interest & note, all I did extra was to fully peruse the Content Manager & saw all my MFS add ons - mostly Orbx & DD Moscow as well,

 

after doing this I immediately checked KBUR & to my surprise - all was fine,

 

I wonder if this could be some sort of ‘scenery layer’ issue in MFS?

 

& double-checked flying from KLAX, in TBM, to KBUR - all worked perfectly,

 

there must be a reason!

Link to post
Share on other sites

That kind of "happening" is one of the reasons that is making the finding of the cause so difficult. It varies from being constant to being random.

It is not a one hat fits all problem.

Link to post
Share on other sites

I've been doing circuits and circuits galore at KBUR and I can get reasonable performance (my midrange computer allows 21 fps at High End settings if I keep Render Scaling to 110 or less).  So, lately I've being associating any extra load on the CPU/GPU with performance drops.

 

For instance the other day one circuit was fine then the AI traffic started to be vectored in by ATC and bang, from 21 to 12 fps or less.  After ATC had gone quiet again the fps went back to normal.  The next circuit, the same thing but three aircraft were being communicated with, by the time ATC went quiet again I was on late final and the fps stayed 10-12 until I had left the airport 5 miles behind.

 

Another time I discovered that my 10-12 fps was because I had Google Earth running as well as MSFS.  I terminated it and got performance back.

 

This appears to be telling me that MSFS uses all the computer's resources so fully that any extra load creates bottlenecks in the CPU and it can sometimes be a while before the CPU deals with the bottlenecks and frees up enough to restore performance.

 

KBUR itself is heavier on resources than many other places, but so is the valley in which it sits.  With the default airport, the region is already taking a few fps off, add in KBUR and a few more fps get lost.  So a system like mine that delivers 30 fps away from Los Angeles, is delivering 21 -24 with the default airport and 17-21 with Orbx KBUR.  As long as nothing else tries to use the CPU, I can do circuits at 17-21 fps with the High End settings.  

 

But if the ATC module activates, it puts a little more load on the CPU and the fps tanks.  So to my mind, because of the way MSFS uses the computer's resources, settings need to be reduced when flying around the Los Angeles area to allow for this extra loading that may or may not drop fps.  Usually I find that dropping the Render Scaling by 20 points the effect on the visuals isn't that great but there is now headroom in the CPU to accommodate extra load such as ATC, AI traffic, weather etc.

 

That's my suggestion, lower the Render Scaling a bit if you're going in to the high load area of Los Angeles  and you might find the large performance drops become smaller at least.

 

 

  • Upvote 1
Link to post
Share on other sites

The problem is far more evident when flying into the airport from another.

Ive flown out of it with little problems. Flying into it is a totally different matter. So doing circuit is not the same as flying into KBUR.

Link to post
Share on other sites
12 hours ago, Nyxx said:

The problem is far more evident when flying into the airport from another.

Ive flown out of it with little problems. Flying into it is a totally different matter. So doing circuit is not the same as flying into KBUR.

 

I just completed two flights in the Citation from San Bernadino to KBUR.  The first flight I had photogrammetry turned on and I had massive pauses of up to a second or two from about halfway through the flight, and about 5 miles from KBUR it said there wasn't enough bandwidth to load photogrammetry so I turned it off.  There were very few buildings on the ground as I turned final and over the threshold the fps tanked to 10 or less.

 

So I reset the flight, but I turned the settings down a click for every variable and made sure photogrammetry was off.  The long pauses disappeared on this leg, just a few 1/4 or 1/2 second pauses around the mid point.  The fps did drop in tis area though, too far away fro KBUR to be having any effect yet I was seeing as low as 14fps, and mostly around 17 fps.

 

Turning final the fps rose again to 21 fps and it remained at 19-21 all the way to touchdown and rollout.  Note that ATC was not active during this last part of the flight.

 

The fact that I was seeing as low as 14fps approaching the Burbank and KLAX area, yet rose to 21 again as turned final to KBUR, indicates to me that the airport is not itself to blame for the severe drop in fps experienced by many of the approaches.  Perhaps KBUR in combination with photogrammetry and ATC being active pushes the sim too far but this flight to me indicates that with suitable settings for this incredibly dense area the airport offers pretty much the same performance as any other.

Link to post
Share on other sites

One if the many variables in this saga.

I have found that if I make any changes via a pause etc to any settings in the Option/General  screen then this can cause the fps to drop to single figures. My last test involved going from Ultra down to High and Apply, then immediately changed it again down a notch to Medium and the fps dropped to 11fps. I then immediately reduced it to Low End and Apply and it stayed at 11fps.

If I have all my settings stable and make no changes to anything, then i can on most occasions get a normal flight.

The major point in all this is that it should not be necessary to have to stop a flight from and airport in order to reduce the settings to accommodate the performance at KBUR. I agree the whole area is dense and demanding but to be able to perform normally with a slight reduction at KLAX with one's normal settings in my case, Ultra and with ai and ATC would be thought to be more demanding resource wise than KBUR. It could well be the combination of KBUR plus the mentioned activity at nearby airports like KLAX that tips the system into dropping fps.

 

Link to post
Share on other sites
22 hours ago, Jon Clarke said:

One if the many variables in this saga.

I have found that if I make any changes via a pause etc to any settings in the Option/General  screen then this can cause the fps to drop to single figures. My last test involved going from Ultra down to High and Apply, then immediately changed it again down a notch to Medium and the fps dropped to 11fps. I then immediately reduced it to Low End and Apply and it stayed at 11fps.

If I have all my settings stable and make no changes to anything, then i can on most occasions get a normal flight.

The major point in all this is that it should not be necessary to have to stop a flight from and airport in order to reduce the settings to accommodate the performance at KBUR. I agree the whole area is dense and demanding but to be able to perform normally with a slight reduction at KLAX with one's normal settings in my case, Ultra and with ai and ATC would be thought to be more demanding resource wise than KBUR. It could well be the combination of KBUR plus the mentioned activity at nearby airports like KLAX that tips the system into dropping fps.

 

 

I will try that and see what i get. Thanks for the tip.

Link to post
Share on other sites
On 10/3/2020 at 5:05 AM, craigeaglefire said:

the strangest thing happened for me with MFS Orbx KBUR,

 

was having serious stutters - unusable,

 

applied latest MFS patch - then activated the Japan update from MFS Marketplace,

 

of interest & note, all I did extra was to fully peruse the Content Manager & saw all my MFS add ons - mostly Orbx & DD Moscow as well,

 

after doing this I immediately checked KBUR & to my surprise - all was fine,

 

I wonder if this could be some sort of ‘scenery layer’ issue in MFS?

 

& double-checked flying from KLAX, in TBM, to KBUR - all worked perfectly,

 

there must be a reason!

I was having staggering single digit FPS at KBUR. Did the above suggestion and my FPS are now in the 40's for KBUR.

Link to post
Share on other sites
On 10/3/2020 at 10:05 AM, craigeaglefire said:

the strangest thing happened for me with MFS Orbx KBUR,

 

was having serious stutters - unusable,

 

applied latest MFS patch - then activated the Japan update from MFS Marketplace,

 

of interest & note, all I did extra was to fully peruse the Content Manager & saw all my MFS add ons - mostly Orbx & DD Moscow as well,

 

after doing this I immediately checked KBUR & to my surprise - all was fine,

 

I wonder if this could be some sort of ‘scenery layer’ issue in MFS?

 

& double-checked flying from KLAX, in TBM, to KBUR - all worked perfectly,

 

there must be a reason!

 

Please keep testing that the fps issue has been resolved as far as your end is concerned by advising if the sudden rise in performance and fps is now consistent at KBUR or was a one off random experience.

Thanks

Link to post
Share on other sites

So is KBUR still being worked? I'm not going to install it yet until I see many others post that it has been fixed. I purchased it on day one release and was one of the first to post about the performance issues. 

Link to post
Share on other sites
21 hours ago, Jon Clarke said:

Please keep testing that the fps issue has been resolved as far as your end is concerned by advising if the sudden rise in performance and fps is now consistent at KBUR or was a one off random experience.

 

just did some tests at KBUR, Jon

 

Photogrammetry on, Ultra & High settings, TBM & Citation CJ4, various demanding Orbx WPP settings, multiplayer on, traffic on, FS-FlightControl connection with moving map - Steam Standard - & on about a 25+Mbps connection,

 

was doing circuits all around, takeoffs & landings - only one hiccup when changing settings mid-flight - & KBUR performed well,

 

as noted, all that was applied was the most recent MFS patch & i fully checked out the addons in the Content Manager (& i am not aware of any Scenery Library management tool for MFS scenery layering).

 

will continue to test for you - & hopefully others chime in with their recent experiences - it is after all high intensity scenery.

 

& some folks are holding of purchasing KBUR 'til this 'issue' is noted as fixed.

 

please feel free to request any further specific tests for KBUR - would be happy to help!

Link to post
Share on other sites

Flew a non stop flight today from KHMT-KBUR. Made sure i changed all if any settings prior to flight. Had a couple hard stutters about 12 miles out, but other then that seemed to go normal. Landed with no issues other a frame drop but nothing to cause any stutters so to speak.. Will do a flight from KBUR tommow and see how it goes. This was mid day flight.

Link to post
Share on other sites
3 hours ago, Wise87 said:

So is KBUR still being worked? I'm not going to install it yet until I see many others post that it has been fixed. I purchased it on day one release and was one of the first to post about the performance issues. 

Yes it is and we must bear in mind that it may not be a KBUR stand alone issue but also related to the sim itself. I say that because some have seen the same performance impact with the default  KBUR as well so is the nature of this issue.

Just to put you more in the picture, the dev is trying all kinds of tests by removing or replacing some objects, adjusting resolutions and a whole load more things but some of the tests results are the same.

The biggest and most difficult aspect of all this is that there are many, probably a minority, that do not have the problem. It is also well noted now in this forum that the issue is for many totally random.

We have the latest report that activating the latest update and checking the Content folder has resulted in a much better performance. That begs the question as to how is the performance issue related to the KBUR addon if it is the change in the sim that has produced a better performance.

I trust that you now appreciate the difficulty in all the attempts at rectifying the problem which may well be nothing to do with the addon itself but possibly a sim problem. 

Link to post
Share on other sites

@craigeaglefire Please oblige and expand a bit more as to what you did regarding the Content Manager, Did you manually place KBUR higher in the list or something?

I ask because I created a new Community folder with only KBUR in it and i could, by making changes during being at KBUR, cause the fps drop to occur.

Link to post
Share on other sites
32 minutes ago, Jon Clarke said:

Please oblige and expand a bit more as to what you did regarding the Content Manager, Did you manually place KBUR higher in the list or something?

 

Jon, i noticed that there were notifications as the Japan Update package modules were being added - this aroused my curiosity so when i clicked on the notifications it placed me in the Content Manager showing all the MFS addons - i learnt something about MFS i hadn't seen previously - got me to wondering how the sceneries were being 'layered', after my experience with P3D & tools like SimStarter,

 

apart from that, i have just now enabled Developer Mode in MFS & put KBUR & MFS under a stress test - switching High-End to Ultra - changing aircraft, mid-flight, with the Aircraft Selector - torture test - & indeed can get the frames to drop at KBUR - 12-16fps whilst landing, @ i am running 4K res,

 

do a normal flight at KBUR after fresh MFS load up & new flight configuration & all seems to work well.

 

 

Link to post
Share on other sites

it is sporadic, Jon

 

& now i am using Dev Mode, the FPS counter has a very good GPU VRAM budget usage tracker,

 

will do heaps more flying at KBUR - it is interesting to check out this conundrum,

 

as always, a reboot of MFS & a full reboot of computer can affect things - & new MFS patches are released fairly regularly at the moment,

 

& what the developers think is happening would also be worth knowing.

Link to post
Share on other sites
Just now, Nyxx said:

Installed the latest drivers. Thought I would give KBUR another try.

Loaded on runway, waited for everything to settle down FPS 30.

 

Started to take off.

Flight-Simulator-KFk-B949-JLl.png

 

Is it possible to get a credit or refund this is the only airport that brings everything to its keens. Its just inop and been like it for a long time and it seems the developer has not found or is close to a solution. From what I read above.

I bought LOWI and LOWW this morning and it was a dream to use both and are huge wonderful detailed airports compare to the size of this. I feel I just wasted my money on this. Very unlike Orbx.

 

  • Like 1
Link to post
Share on other sites

Hi Jon and others, I did another flight, in around, leaving, and approaching KBUR with the latest patch 1.9.5.0.  From what I can tell the sim has an overall improvement in performance in all areas of the world I flew in, however KBUR still has the same amount of massive performance drop not seen in any other Orbx airport I own nor other third party airports so there is still something native with the airport scenery going on.  As it is still the only place where I'm still hitting single digit FPS even in steam gauge aircraft like the 152 aerobat.  Here are some metrics, but please let me know if there are other details I may be able to provide or test cases you'd like me to try.  Since KBUR I've been holding off future MSFS purchases, to patiently wait to ensure this gets corrected first and hoping you guys are on the track!

 

i7 7700k stock configuration

GTX 1080 w/ 456.71 drivers

MSFS 1.9.5.0

 

Thanks all.

Link to post
Share on other sites
5 hours ago, Todd said:

Just a short observation, but the recent MSFS release 1.9.5.0 has surprisingly improved overall performance and smoothness in my representative 10700K + 2080 Super rig. The metrics seen using GPU-Z shown a very significant drop in GPU average TDP and Temp and accompanied by the elimination of frequent GPU power limit throttling that produced stutters in taxing scenery/aircraft situations. KBUR is now smooth and I have been able to takeoff and tight-circle to land back at KBUR in the A320 without stutters while maintaining ~30 FPS with vsysnc off and just relying on the nvidia gysnc feature to dynamically manageireduce the frame rate as needed.

 

Anyway, KBUR is still a bit slower than comparable sceneries but the very low FPS and stutters are now gone for on my rig.

 

Nick, I know this observation probably does help much, but it suggests that a major part of the performance problems rest with the constantly evolving/fixing-up of MSFS. Patience indicated for sure.

 

Todd

 

34 minutes ago, hawkeye52 said:

Hi Jon and others, I did another flight, in around, leaving, and approaching KBUR with the latest patch 1.9.5.0.  From what I can tell the sim has an overall improvement in performance in all areas of the world I flew in, however KBUR still has the same amount of massive performance drop not seen in any other Orbx airport I own nor other third party airports so there is still something native with the airport scenery going on.  As it is still the only place where I'm still hitting single digit FPS even in steam gauge aircraft like the 152 aerobat.  Here are some metrics, but please let me know if there are other details I may be able to provide or test cases you'd like me to try.  Since KBUR I've been holding off future MSFS purchases, to patiently wait to ensure this gets corrected first and hoping you guys are on the track!

 

i7 7700k stock configuration

GTX 1080 w/ 456.71 drivers

MSFS 1.9.5.0

 

Thanks all.

 

I think comparing the two statements above is quite interesting.

Link to post
Share on other sites

It certainly re-emphasises the complex and very random nature of the issue which, to add to the mix, is still not experienced by all users. I do concede though that it is a significant number of users.

Link to post
Share on other sites

Locking this now.


The main model object of KBUR is a single large model and Asobo have recommended it be split into smaller portions and recompiled. Matteo will be working on that as a potential solution which we anticipate to come into internal testing at month end.

  • Like 3
Link to post
Share on other sites
Guest
This topic is now closed to further replies.
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...