Jump to content
Nicky Bird

Stutter every minute

Recommended Posts

Anyone getting this issue. 
so I’ve updated graphics driver (states in the topic above) 

and now every minute or so in the sim I get one very pronounced stutter. Which I didn’t have before. Is there a way round this? Anyone else get this issue. I got a hefty pc. And settings are moderate so it’s not pc or settings related. 

cheers

Share this post


Link to post
Share on other sites
12 minutes ago, Nicky Bird said:

Anyone getting this issue. 
so I’ve updated graphics driver (states in the topic above) 

and now every minute or so in the sim I get one very pronounced stutter. Which I didn’t have before. Is there a way round this? Anyone else get this issue. I got a hefty pc. And settings are moderate so it’s not pc or settings related. 

cheers

 

Try DISABLE FULLSCREEN OPTIMISATIONS and then restart your pc and reload. works for loads of games/sims

Untitled-2.jpg

Share this post


Link to post
Share on other sites

Yeah I did this too. Still didn’t work for me I’m afraid. Also disabled AV and still no luck

 

Nick

Share this post


Link to post
Share on other sites

So I did a flight. LEBB to LEAS in the 787, nice and short. And I was getting stutters every 3 or so seconds. I didn’t have this before. I rolled back my driver and it still occurred. 
 

im stomped, I don’t even know where to start 

Share this post


Link to post
Share on other sites

Check you have the right program selected in Program settings in NVIDIA control program

image.thumb.png.86163444a7c54fbd553c9e09047b16d2.png

Share this post


Link to post
Share on other sites

So I figured out what it was...its so basic too! i feel so stupid!

 

My previous settings: 60Hz resolution, in sim was vsync=ON, TB=ON, Frames=Unlimited

which was the cause of the stutter, so i played around with these settings.

 

my new settings: 50Hz resolution, in sim is now vsync=ON, TB=OFF, Frames=43

Smooth as butter, no stutters.

 

(this is with  'Disable fullscreen optimisation' and 'image sharpening at 0.56')

 

I got a hefty PC spec, but I'm humble and happy with it, sliders are not maxed but all a slider below. 

 

Thank you for your time gentleman! 

 

Birdy

Share this post


Link to post
Share on other sites
Posted (edited)

This worked for me and the stuttering issues I had in P3D v5.       

 

1CCC1670-A2AC-4715-86D6-D456D9F34A6D.jpeg

Edited by Pattersb

Share this post


Link to post
Share on other sites
Posted (edited)

So I did a flight. On the ground I’m good, it’s smooth with the settings I’ve just made. Did a small hop in my 787 from LEBB to LEAS. And I got a regular stutter ever 3 seconds on approach on LOC for runway 29 LEAS. And this stutter continued until I vacated the runway..it then stopped. Didn’t have any issue in LEBB. Just on approach to LEAS. 
I’m  going to do another flight later. And test the approach on the other runway. And see what happens. It might

be scenery optimisation, who knows..we’ll see. I’ll do flight to LEBB and test the approach on there too and see what I get.

Edited by Nicky Bird

Share this post


Link to post
Share on other sites

Further testing. Didn’t actually work. Stutters every 3 seconds. Even dialed the sliders down. I may revert to p3d HF1 and see if it’s a HF2 issue

Share this post


Link to post
Share on other sites

Ok, cant get rid of the stutter every 3 seconds, I've literally ran out of things to do, I thought I got rid of it, but I haven't. ive reverted back to HF1, nothing, so im back on HF2.

 

I'm at a loss and feel so defeated

Share this post


Link to post
Share on other sites

so after some long testing last night. its down to refresh rates and in sim fps setting. all sorted now.

 

plus - QW 787, turning on terrain radar will induce a prominent stutter every 3 seconds.

 

kind regards.

 

Birdy 

Share this post


Link to post
Share on other sites

Turning off hyperthreading in the bios also helps.. and if you have the RAM to cope, turn off your virtual memory in windows performance manager.

Share this post


Link to post
Share on other sites
On ‎6‎/‎29‎/‎2020 at 11:49 AM, Nicky Bird said:

its down to refresh rates and in sim fps setting. all sorted now.

 

Would you mind sharing your solution? I still struggle with those regular 3 second stutter over some sceneries (e.g. TE Netherlands). But my G-SYNC 144Hz monitor setup somehow makes things complicated, as those 30Hz/30FPS or 1/2 refresh rate "tricks" are useless for my monitor setup. I tried limiting the monitor to 120Hz and use 1/4th, I tried using dynamic refresh rate with G-Sync on, I tried disabling G-Sync specifically for P3D. Nothing works, nothing gets rid of those stutters. Add the fact that my monitor (DELL S2716DG) supports G-Sync only from 30FPS upwards (which is exactly the FPS I am aiming for in P3D), and things get even more complicated...

 

And, as a matter of fact, I did not have those annoying stutters back in v4.5 of P3D. Which tells me that something must be different in v5, but I simply do not find the solution. Really annoying.

Share this post


Link to post
Share on other sites

@AnkH

 

yeah I’ve had the same issues, I’ve tried all kinds of settings, But I always end up with really laggy panning, stutters or tearing. I’ve even got a full V5 install now to eliminate me missing anything but it didn’t make a difference. I’ve spent hours trying to figure it all out. 

 

in the end, for now, I’ve settled for the following settings:

 

144hz resolution monitor

 

NCP - 1/2 refresh rate And prefer maximum performance. 
 

In sim - set frames to 30, sync - on and TB - off

 

- additional note:

 

I also disabled full screen optimisation On the P3D.exe

 

and windows 2004 GPU scheduling - On 

 

Now these settings are a compromise, I get no stutters, smooth scenery loading, but...when you pan around the cockpit, it’s not 100 butter smooth but then it’s not going to give me a headache too and there’s no tearing. It performs well in TEGB and TENL, even flytampa EHAM. My settings are all 3/4 to the right.

 

if I was to take the limiter off and put it too unlimited, it’s butter smooth ...but stutters come back. This is me using the QW 787, even putting on the terrain radar I’ve noticed induces a big stutter every 3 seconds (more prominent).

 

unfortunately, with p3d, frames are all over the place in different locations, you might set it to unlimited and TEGB EGKK will hit you at 30 fps and will really ruin the immersion. 
 

after all my testing and trying other people’s settings, keeping it simple helped, go basic. Feel free to try my settings, see if it works.

 

my monitor is 144hz and I may just only change it to 60hz today to see what difference it’ll make.

 

good luck on your journey 

Share this post


Link to post
Share on other sites

 

ok so i made a few changes. as i still wasn't satisfied.

 

144hz monitor

 

Orbx vector - unticked everything (you still get your coastlines just not roads but im yet to slowly add them back until I stutter) 

 

NCP - prefre max performance

 

In Sim - set fps to 30 (ive come to the conclusion p3d doesnt play well with frames above 30/35...or maybe just for my monitor anyway, i got any higher than that, i get stutters)

 

 

Share this post


Link to post
Share on other sites

Interesting, so you disabled again the "1/2th refresh rate" VSYNC in the nVIDIA driver? Above settings are exactly what I have now, with the difference that I limited my 144Hz monitor to 120Hz to have an equal multiplier of my FPS limit of 30. Those 3 second stutters remain on certain sceneries such as TE Netherlands. Now with HF2, Hardware-scheduling turned on an the newest nVIDIA driver, they are less prominent though. But still visible and annoying.

Share this post


Link to post
Share on other sites

So I’ve spent many hours trying to figure it all out. More hours messing with settings a tweaks and I truly believe, it’s nothing to do with hardware. It’s just the sim. I watch youtubers, and I can see they have the stutters too. Maybe it’s just a p3d thing.

my settings change to what aircraft I use also. So far, I can’t find a happy medium, I have a 144hz monitor. And running at 30 FPS Is great for stutters of scenery, but gives me a headache while planning around in the cockpit because it’s not as fluid than running at unlimited (at the cost of stutters. More testing is needed. But I’m hoping it’ll get better through p3d updates

Share this post


Link to post
Share on other sites

Do you have Orbx vector? As I found this to be a big player in stutters. So I deselected almost all checkboxes and it reduced stutters

Share this post


Link to post
Share on other sites

The stutters I observe, primarly over TE Netherlands, were already there before I installed FTX Vector for v5. The installation of Vector did not change much on my system, just the loading times are slightly longer. Due to the fact that the stutters are absolutely regular, I guess it MUST be related to some sort of setting inside the sim that does not go along well with some other setting outside of the sim, but whatever combination I try, the stutters remain.

 

Might be that there is no solution to this...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...