Jump to content

answered P3D v5 HF2 Won't Completely Exit After KBUR Install


Recommended Posts

Last week I did a full format and reinstalled Windows, and then waited for HF2 for P3D v5 to be released before I installed P3D again.  Now that it's been released I have begun reinstalling software, piece by piece, so as to ensure compatibility and stability.  I'm very methodical about this, so if there is a problem I can pinpoint exactly what's causing it.

 

This morning I installed Orbx Burbank, and I've run into a problem with P3D.  Following the KBUR install P3D won't exit completely.  I hit the X and the sim goes away, but in my task bar the microphone says it's still being used by P3D.  This is minutes after I've closed P3D.  I know it usually takes about 30 seconds or so to exit on my machine.  This was at least 5 minutes after I exited.  A check of task manager confirmed that P3D.exe was still running.

 

I ended task on P3D.exe, then loaded it up again, placing myself again at gate A4 at KBUR.  Exited P3D and had the exact same issue.  P3D would not finish exiting.  I had to end task again.

 

So to verify that Burbank is causing this problem, I uninstalled Burbank, then loaded P3D back up and went back to the same gate at KBUR. then exited P3D and it closed normally in about 10 seconds.

Edited by gollum65
Link to post
Share on other sites

BTW, before I ended task the first time on P3D.exe, I checked the Windows Event Viewer.  There were no errors showing in the Applications or in the Systems logs.  After ending task, the following error was showing in the Application log:

 

Log Name:      Application
Source:        Application Error
Date:          6/24/2020 5:49:00 AM
Event ID:      1000
Task Category: (100)
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      DESKTOP-32QVMGM
Description:
Faulting application name: Prepar3D.exe, version: 5.0.31.35253, time stamp: 0x5eebf566
Faulting module name: sapi.dll, version: 5.3.24603.0, time stamp: 0xc15b2017
Exception code: 0xc0000005
Fault offset: 0x000000000009d27d
Faulting process id: 0x254c
Faulting application start time: 0x01d64a23eb18d881
Faulting application path: D:\P3Dv5\Prepar3D.exe
Faulting module path: C:\Windows\System32\Speech\Common\sapi.dll
Report Id: 2d5902c2-e48e-40d2-9942-3c73292c3577
Faulting package full name: 
Faulting package-relative application ID: 
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="Application Error" />
    <EventID Qualifiers="0">1000</EventID>
    <Version>0</Version>
    <Level>2</Level>
    <Task>100</Task>
    <Opcode>0</Opcode>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2020-06-24T12:49:00.8664315Z" />
    <EventRecordID>3070</EventRecordID>
    <Correlation />
    <Execution ProcessID="0" ThreadID="0" />
    <Channel>Application</Channel>
    <Computer>DESKTOP-32QVMGM</Computer>
    <Security />
  </System>
  <EventData>
    <Data>Prepar3D.exe</Data>
    <Data>5.0.31.35253</Data>
    <Data>5eebf566</Data>
    <Data>sapi.dll</Data>
    <Data>5.3.24603.0</Data>
    <Data>c15b2017</Data>
    <Data>c0000005</Data>
    <Data>000000000009d27d</Data>
    <Data>254c</Data>
    <Data>01d64a23eb18d881</Data>
    <Data>D:\P3Dv5\Prepar3D.exe</Data>
    <Data>C:\Windows\System32\Speech\Common\sapi.dll</Data>
    <Data>2d5902c2-e48e-40d2-9942-3c73292c3577</Data>
    <Data>
    </Data>
    <Data>
    </Data>
  </EventData>
</Event>

Link to post
Share on other sites
Posted (edited)

Thanks for the response.  Since I reported this issue, then uninstalled Burbank, I've installed FSDT DFW, Aerosoft EDDF,. and FlyTampa Boston, and none of them cause this issue.  Even LVFR Miami, which is a terribly optimized scenery, does not cause this issue.  I just now reinstalled Burbank.....exited and waited about 5 minutes....P3D process still running.  Ended task on it, uninstalled Burbank, then went back to the default airport.  P3D exited in about 30 seconds.  So it's definitely this scenery that's causing the problem.  Doesn't matter if I have PBR on or off, or static aircraft on or off in the scenery, the behavior is the same.  Is there any way to figure out what is causing the P3D process to hang/refuse to shut down?  Some software I can install that would track the processes and identify the interractions?

Edited by gollum65
Link to post
Share on other sites

Here are a few more things I tried.  I updated my nvidia drivers to the release from yesterday.  I'm running a 2060 Super.  I tried loading at one of the "lite" airports in the package, Whiteman, and still had the same problem where P3D wouldn't exit.  I then installed FSDT LAX and LVFR KSAN and tested them.  Both worked fine and P3D exited without a problem.  I was then curious if I started in the area covered by the KBUR package and flew out of the area, would I still have the problem, presuming that the scenery would be unloaded once I got far enough away.  So I took off from Burbank in the default P3D Mooney Acclaim, overflew the terminals at LAX, then flew south and landed at Long Beach, which is probably a 45 mile flight or so?  I landed at KLGB and exited P3D and it exited fine.  So it's clearly only an issue when the Burbank package is loaded into memory.  Once you leave the area the problem goes away.  I suppose I could make all my Burbank flights departures?  Not really a solution, but at least I can use it.

Link to post
Share on other sites

I do not know, i do not have any problem to exit p3d when i use kbur ( but i do not have HF2). The scenery has nothing that could cause this problem. The fact you are experiencing the issue just with kbur is weird. Probably could be a bug in the new " HF2 " or because of the heavy area. Maybe try to disable sca( if you have ) and reduce the setting of p3d and try to see if is the same or not. I do not have a solution to your problem at the moment sorry.

 

cheers

Link to post
Share on other sites

Ok I'll just do departures out of Burbank then.  Don't know if that's worth what I paid, but if that's what I have to live with I guess.  I do not have Orbx SoCal.  Just Base and Vector.

Link to post
Share on other sites
9 minutes ago, gollum65 said:

Ok I'll just do departures out of Burbank then.  Don't know if that's worth what I paid, but if that's what I have to live with I guess.  I do not have Orbx SoCal.  Just Base and Vector.

Try to play with setting, just to know if make some difference. I am sorry that you are having this issue, i know can be a pain.

If i will have some new ill let you know :)

anyway why you do not kill the process of p3d in the task manager when you exit? I think is very simple and fast to do.

 

 

Cheers

Link to post
Share on other sites

Yes, I can certainly kill the process but it's always been my understanding that forcefully killing a program that's not closing on it's own is bad for it.  But I'm not a programmer so I don't know.  I can try to set my graphics settings all the way to their lowest values and see if that makes a difference?  If it doesn't then it doesn't matter what the settings are.

Link to post
Share on other sites
56 minutes ago, gollum65 said:

Yes, I can certainly kill the process but it's always been my understanding that forcefully killing a program that's not closing on it's own is bad for it.  But I'm not a programmer so I don't know.  I can try to set my graphics settings all the way to their lowest values and see if that makes a difference?  If it doesn't then it doesn't matter what the settings are.

Yes, try to play with the setting. Maybe start with all low and see if makes some difference.

 

Cheers

Link to post
Share on other sites
25 minutes ago, Braun said:

Do you use the F1-GTN by chance?  Ver 2.20 is proven culprit of HF 2 exit hang. 
-Braun

Thanks Brian,. but no I don't.  And nothing else I have in the sim so far causes the exit hang.  Only this scenery.

Link to post
Share on other sites

So some more info about this, and I hope it helps figure out the problem.  I went and created a settings profile with all my settings on the Display and World tabs set to their absolute lowest.  I then loaded up at KBUR on rwy 15 in the default F35 and exited P3D, but it still hung.  So I took a look at my system processes that were still running.  Besides P3D there wsa the Couatl engine, which I ended task on.  No change.  Then I found the SODE engine was still running and ended task on that, and about 10 seconds later P3D exited on it's own.  So I'd say you need to look at how the scenery interacts with SODE because it seems like that's what's causing it to hang.

 

Hope that helps resolve it.

Link to post
Share on other sites
18 minutes ago, gollum65 said:

So some more info about this, and I hope it helps figure out the problem.  I went and created a settings profile with all my settings on the Display and World tabs set to their absolute lowest.  I then loaded up at KBUR on rwy 15 in the default F35 and exited P3D, but it still hung.  So I took a look at my system processes that were still running.  Besides P3D there wsa the Couatl engine, which I ended task on.  No change.  Then I found the SODE engine was still running and ended task on that, and about 10 seconds later P3D exited on it's own.  So I'd say you need to look at how the scenery interacts with SODE because it seems like that's what's causing it to hang.

 

Hope that helps resolve it.

Hi the scenery does not use sode at all.

 

Cheers

Link to post
Share on other sites

Hello,

 

apart from the product not using SODE, the logic in your post:

 

Quote

I then loaded up at KBUR on rwy 15 in the default F35 and exited P3D, but it still hung.  So I took a look at my system processes that were still running.  Besides P3D there wsa the Couatl engine, which I ended task on.  No change.  Then I found the SODE engine was still running and ended task on that, and about 10 seconds later P3D exited on it's own.  So I'd say you need to look at how the scenery interacts with SODE because it seems like that's what's causing it to hang.

 

is flawed.

SODE opens and closes with P3D, so if P3D is kept open, SODE cannot close.

You saw that SODE closed after P3D did, so it should be clear what is keeping P3D open.

I do have P3D v5.0.31.35253 and KBUR installed.

 

As a test, I loaded at KBUR runway 15 and saw this:

4.jpg

 

then I closed P3D and a few moments later, saw this:

5.jpg

 

 

 

Link to post
Share on other sites

Sorry Nick, but that's not what I said, and not what happened.  What I said was that P3D wouldn't close until I ended task on SODE.  Since SODE is always running no matter where in the world I go, and the only time I have a problem with P3D not closing is when in I'm the Burbank scenery area, and ending task on SODE got P3D to close, the only conclusion is that Burbank is somehow causing SODE to hang P3D.

 

At this point I'm getting pretty frustrated and I'd like to know how to request a refund.  I no longer have interest in dealing with this problem if Orbx and the developer aren't willing to even try to find out what;'s wrong.

Link to post
Share on other sites
45 minutes ago, gollum65 said:

Sorry Nick, but that's not what I said, and not what happened.  What I said was that P3D wouldn't close until I ended task on SODE.  Since SODE is always running no matter where in the world I go, and the only time I have a problem with P3D not closing is when in I'm the Burbank scenery area, and ending task on SODE got P3D to close, the only conclusion is that Burbank is somehow causing SODE to hang P3D.

 

At this point I'm getting pretty frustrated and I'd like to know how to request a refund.  I no longer have interest in dealing with this problem if Orbx and the developer aren't willing to even try to find out what;'s wrong.

Hi,

 

I think this is not right, i am trying to help you. I am saying sode does not have nothing to do with the scenery. The scenery is just 3dmodels with textures, it does not have sode or material script that could cause problems. I told you that the cause could be due to the heavy area, and try to reduce the setting to see if makes some differences. I can not do more than this, moreover this is the first case i hear a problem like this. 

 

cheers

Link to post
Share on other sites

Hello.

Not agreeing with your diagnosis is not the same as not attempting to provide product support.

Matteo has explained to you that the product does not use SODE at all.

As it does not, it cannot interact with it.

In the light of that, and my demonstration that with his airport, SODE, your version of P3D v5 and your scenario, the problem does not occur,

perhaps you could at least consider the possibility that the problem could lie elsewhere?

If you replicate the scenario but at another airport where you are using GSX, do P3D, GSX and SODE all close?

 

Link to post
Share on other sites

Yes, I use payware aircraft (PMDG 747 and QW 787 curreently), at only payware airports (I currently have about a dozen installed). always using ASP3D, GSX, UGCX, and flying on VATSIM.  The only time I have a problem with P3D closing is when I'm in the Burbank scenery area.  

 

Also, as I described above, I did a test where I put all my display and world settings to their absolute lowest, and P3D still wouldn't close if I was in the Burbank scenery area.  On top of that, as I detailed the other day, if I took off from Burbank and flew out of the area covered by the scenery, landed, and closed P3D it closes normally.

 

So the ONLY time P3D won't close on my machine is when I'm in the Burbank scenery area, whether SODE or GSX or anything has to do with it or not?  I always use all those add ons for every flight and P3D never has a problem closing if I'm not within the Burbank scenery area.  I don't know if the SODE thing was a coincidence or not?  The fact remains that the only time I have this problem is in the area covered by the Burbank scenery package.

Link to post
Share on other sites

Let me just say, I'm not trying to be difficult.  Burbank is literally one of my favorite airports in the world and I was thrilled to see it come out.  But I'm not going to use it if using it causes a problem with P3D.

Link to post
Share on other sites

Thanks, my suggestion is that it does not cause a general problem with P3D at all but that there is a possibility that the combination of software

that you use might contribute.

Apart from the inconvenience of having to manually close P3D after ending your session at KBUR, are there any other adverse effects at all?

Link to post
Share on other sites

Not that I've seen so far, but I'm not fond of manually ending task on software.  My understanding is that every time you do it could cause that software to become corrupt.  Maybe that's old school thinking?  I don't know.  But I did tech support for a living for many years and would always try to avoid having customers end task on a hung program, and if I had to then I would do everything I could to try to figure out what caused it to hang in the first place?

 

I guess at this point I could try to reinstall the P3D client?  I don't know what else to do?  I've uninstalled and reinstalled Burbank numerous times.  When it's installed and I'm at Burbank, even if I just spawn up on the runway and then close P3D, P3D refuses to close.  When I uninstall Burbank, then repeat the same process with the same scenario, P3D closes normally.

 

This was a completely fresh install of P3D on Tuesday, when HF2 came out.  I can uninstall and reinstall the client?  Or is it possible that something in the scenery component is conflicting?  There was mention in the HF2 update notes that they updated Burbank Airport.  Could the default airport somehow be conflicting with the Orbx one?

Link to post
Share on other sites

Hello,

I can't really answer the questions except to point out that, of the additional software that you have installed in your copy of P3D v5,

the only one I have is SODE and that using your scenario of loaded at runway 15 of KBUR, P3D v5 closes normally.

I don't mean to be unhelpful, I simply cannot replicate the problem.

As a matter of interest, I use a batch file to open and close P3D v4 and so far, after over a year of use, it has not damaged it.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...