Jump to content
The Merowinger

resolved massive problems with sceneries in V5

Recommended Posts

after switching to prepar3D v5 and deleting/uninstalling the 4.5 version and its addons I decided to use only the XML-method now. In v4 everything was installed in the sim-folder and was managed via sceneryconfigeditoe. It's a nice tool but it's not able to handle XML-addons so I decided to use simstarter for sorting my addons in an order. Sorting is important for me because I have a lot of addons and I don't like waiting hours until everything is load; that's why I activate only things I need.

But something is wrong. I did a fly over Munich and it Looks horrible; Nuremberg too; empty places in the city. I have global, openLCEurope and GEN/GES installed. GEN/GES are above openLC and this is above global base. The Orbx libs are on top of them. It's the same order I used in V4. I tried dozens of hours to fix it, did resync, did verify files, had a look at the Insertion points - no changes. I don't know what to do more. Has anybody an advice for me? I'm consider to put the whole Thing back into the sim, maybe this helps.

 

Kai

Unbenannt-1.jpg

Unbenannt-1a.jpg

Unbenannt-2.jpg

Unbenannt-3.jpg

Unbenannt-4.jpg

Unbenannt-5.jpg

Unbenannt-6.jpg

Share this post


Link to post
Share on other sites

Just made a quick check and Munich looks normal on my system under P3D5. The first thing I'd try would be Check files for GES.

 

Anyway, the scenery hierarchy in those Orbx P3D5 installations (including mine) is a miracle to me. Would it be possible for Orbx to publish a complete list of all sceneries in the proper order and pin it in the P3D5 forum? That would be really helpfull, I think.

 

Kind regards, Michael

Share this post


Link to post
Share on other sites
Posted (edited)

Thank you Michael,

 

I tried verify files already and there was Nothing missed; no files were downloaded again.

Yes, such a hierarchy, especially for packages including the priority of their layers would be very nice.

Btw. Michael, do you use the library method or are you installing into the sim rootfolder?

 

Kai

 

Maybe they aren't compatible yet with V5?

Edited by The Merowinger

Share this post


Link to post
Share on other sites

Hi Kai,

I Have all the Orbx EU sceneries installed in Orbx library, running the very same scenery settings as you do and don't have any problems. When problems like that occur to me I usually regenerate the "SceneryIndexes_x64" folder (C:\ProgramData\Lockheed Martin\Prepar3D v5), then in Windows program and features I right click on Prepar3d client, content and scenery and choose repair. It helped a couple of times on my system, no setting or .cfg or anything is changed. Just give a  shot, it's just a few minutes and might help.

Mick

  • Thanks 1

Share this post


Link to post
Share on other sites

Another idea would be to Sync the simulator (under Help). From your shots I feel custom buildings are present while autogen seems to be missing. Syncing the simulator restores several autogen files which may have been overwritten by 3rd parties.

 

Kind regards, Michael

  • Thanks 1

Share this post


Link to post
Share on other sites
Posted (edited)

the sync-function I used already, several times, thanks Michael.

It looks as if the autogen defintions are not merged (or declared) in the sim. There is no entry in the autogen.cfg  and the default.xml is untouched. Is it possible that somethings prevent that decaring process? What will be nessesary to trigger the sim to load the autogen entries into the sim? Is it possible for me to regognize it, apart from having nice autogen Buildings?

 

Kai

Edited by The Merowinger

Share this post


Link to post
Share on other sites

can you post your " Autogen " folder content?

Share this post


Link to post
Share on other sites

did you installed any scnery from France VFR or run the compatibility "setupAGX64" file? Because it looks like a compatibility setup has been executed. The "default.xlm" when Orbx stuff is installed has a size of  27010.000KB. Yours 7.652.326. Make a uninstall of the Orbx libraries and than a New Install, that should help.

  • Like 2

Share this post


Link to post
Share on other sites

I solved this Problem: I deinstalled all addons, made a repairinstallation of P3D, after that the Orbx-entries and now Munich Looks like it should be. But now I have to find out, which addon was Blocking the autogen-entry from GES. I used one addon, Slowenia photo which Comes with own autogendefinitions, build in via autogen.cfg. Maybe I should use the ACM-tool again?

 

Kai

Share this post


Link to post
Share on other sites
Posted (edited)

No! If you use it again you will get the same autogen conflict! I have Slowenia also. But some of the buildings have black walls. In time of P3D v4 I used only photoreal sceneries without Orbx Sceneries installed there where no problems.

Photoreal sceneries like Slowenia and all other Photoreal stuff are not really compatible with Orbx seneries

Edited by pezi

Share this post


Link to post
Share on other sites
7 minutes ago, The Merowinger said:

Maybe I should use the ACM-tool again?

 

I would try to avoid this, at least I will try it myself. In P3D5 (and already in 4.5) you have the possibility to merge different autogen definitions natively using simulator means. You have to keep the autogen in separate folders parallel to /scenery and /texture and make entries in the autogen.cfg file (I think that's the one). I didn't do it myself (yet) but that's the plan when I'll come to marry my France VFR sceneries with Orbx in P3D5. According to the France VFR forum this should be possible (there are recipes given), and the same should apply to other sceneries modifying autogen entries. You only have to avoid the installer to simply override simulator entries (as you just learned |-) )

 

Kind regards, Michael

Share this post


Link to post
Share on other sites

 

8 minutes ago, pmb said:

I would try to avoid this,

Michael

But wouldn't it be easier and safer to let ACM do its job? or is it not working fine in V5?

Another reason to hold from going into v5 for me

Thanks

Carlos

Share this post


Link to post
Share on other sites
7 minutes ago, carlosqr said:

 

Michael

But wouldn't it be easier and safer to let ACM do its job? or is it not working fine in V5?

Another reason to hold from going into v5 for me

Thanks

Carlos

As far as I know, ACM does work in V5 and you can still do it that way. I'd just try to use the native procedure as suggested by LM. I've read from people who did it that way (i.e. using additional /autogen directories) but will reserve final judgement until I've proven it to work myself.

 

Kind regards, Michael

  • Thanks 1

Share this post


Link to post
Share on other sites
3 minutes ago, pmb said:

As far as I know, ACM does work in V5 and you can still do it that way. I'd just try to use the native procedure as suggested by LM. I've read from people who did it that way (i.e. using additional /autogen directories) but will reserve final judgement until I've proven it to work myself.

 

Kind regards, Michael

Thank you Michael

I'd love to hear about your testing

Cheers

Share this post


Link to post
Share on other sites
1 hour ago, pmb said:

You have to keep the autogen in separate folders parallel to /scenery and /texture and make entries in the autogen.cfg file (I think that's the one)

That method was not reliable in 4.x; I've read. That's why I used the ACM there and I was very satisfied. In theory you are right of course, Michael. Hopefully in V5 it will working stable; I'll try Slowenia tomorrow again. It should work like Austria Pro or FranceVFR.

 

Kai

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...