Jump to content

Recommended Posts

Hi all.

 

Need some advice.

 

I'm switching to P3D.

  • Should I get Version 4 or 5?
  • Will my Orbx scenery files be compatible with V5? Main interest here is for Australia V2 and associated airports / City Scenery. I do have most of North America as well.

 

Thx

 

Mike

  • Like 1

Share this post


Link to post
Share on other sites

V5 for sure and most of the AU airports will work in V5 also .

 

Cheers

 

John

  • Like 1

Share this post


Link to post
Share on other sites

If you step in right now then I would suggest V5 indeed but that is up to you. V5 needs to be polished but it will be done as we go along. Can you cope with that? Many people can't and stay with V4 or use them both like I do. Attention to V4 will faint when V5 gets stabilized. Maybe 60 euros (180 AUD?) is much, maybe not but the price of installing all again when you decide to go for V4 now and switch to V5 after a year will be greater I guess.

Share this post


Link to post
Share on other sites

Your choice watch videos and twitch :P 

 

V5 add-ons are being updated and supported slowly. And expecting more patches for V5

Share this post


Link to post
Share on other sites

Thx. V5 it is.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...