Jump to content

Recommended Posts

Hello,

I have many KERNELBASE.dll error when close the simulator from an Orbx Scenery.

 have seen this error on Avalon (YMAV), on all the airports of the Norway Region, on Visby (ESSV) - I have not tried other scenarios but I have seen that it does NOT happen on OpenLC and default scenarios or Australia v2 and default scenario.
To install Prepar3Dv5 I formatted the computer (Windows 10) and there is only the simulator (NOT in Program files (x86) and programs like FSUIPC, GSX.
I hope I can find a solution thanks

 

Paolo

  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)

Update.

I have this error if start the flight from a Orbx Scenery too.

Edited by Fardel

Share this post


Link to post
Share on other sites

This error is due to an operating system issue and is not caused by the sim or add-ons. Do a web search on Bing/Google/whatever and you'll see it's triggered by all sorts of programs, and you'll see all sorts of fixes, none of them specific to the program that happened to expose the system issue. The good news is it's apparently not too hard to fix.

Share this post


Link to post
Share on other sites
Posted (edited)

Ok but I have this error only on Orbx scenery due Prepar3Dv5

Edited by Fardel

Share this post


Link to post
Share on other sites
Posted (edited)

Hello. I have the same problem, kernelbase error after a few minuts on ESSA Orbx airport, with different aircraft. After reading this post I uninstalled the airport: no CTD. Installed again and CTD was back. I have P3D 5 with HF1.

 

Igor

 

p.s.

it is strange, but I have the CTD on ESSA also an my installation of P3D 4.5 hot fix 3.

Edited by Igor Bischi

Share this post


Link to post
Share on other sites
Posted (edited)

The same for me without Scenery no errors.

May be ObjectFlow.dll? becouse I have not this error on FTX OpenLC and in this there is note the dll.

 

(Sorry for my bad english) :)

 

Paolo

Edited by Fardel

Share this post


Link to post
Share on other sites

I have had a number of these over the past day ... in v4.5 HF3.  The main culprit seems to be the ActiveSky Beta.  It will also depend on how complex an aircraft you are using.

Reverting to ActiveSky for P3Dv4 has solved my issues.

Share this post


Link to post
Share on other sites

I tried without ActiveSky and I have the same problem 

Share this post


Link to post
Share on other sites

I didn't use AS in my tests. And in my case doesn't depend on aircrafts. Today I tried default F22 and A2A V35, with the same result: kernelbase CTD with ESSA and no CTD without.

Share this post


Link to post
Share on other sites

This Kernelbase.dll error was driving me insane a couple of months ago in v4.5. what helped eventually, I deleted p3d generated files, abandoned nvidea inspector, lowered my in game settings and lowered my cpu oc. All that after numerous Windows + Prepa3ed reinstalls. Just give it a shot.

Share this post


Link to post
Share on other sites

Just telling what worked for me after days of try and error.

Share this post


Link to post
Share on other sites

I did the test and I disabled ObjectFlow.dll from add-on and all works fine. No errors when I close the simulator.
Please check the ObjectFlow.dll
Thanks

 

Paolo

Share this post


Link to post
Share on other sites

There is no issue with ObjectFlow.dll  This is an Operating System issue. I will look deeper into it though. You could try the generic fix in CMD. Open CMD as Administrator type sfc /scannow let it run, re boot, try the same scenario and see if it resolves the issue.

Share this post


Link to post
Share on other sites

I'm sorry but this non solve the problem. The Windows is a new installation.

  • Upvote 1

Share this post


Link to post
Share on other sites

I shall give you some advice I was given and it did help.

 

"Get ALL available C++ and Visual C libraries from Microsoft, all you can lay your eyes upon.
Then run Windows Update and make sure the switch in "Advanced options" called "Receive updates to other Microsoft products" is set to On."

 

It's all about Windows 10 & DX12 which are causing the problems.

Share this post


Link to post
Share on other sites

Appie,

 

           I have edited your post, conspiracies are not welcome here. Facts are what matters.

  • Like 2

Share this post


Link to post
Share on other sites

Nobody makes conspiracies. I'm just trying to fix a problem

Share this post


Link to post
Share on other sites

It is a very sad day when I submit a post to try and help, and then it is edited. What I said is a known fact and not a conspiracy. I do not look for brownie points from anyone just trying to help with the very little knowledge I have. You can ban me for life now ...... but I look at the BIG PICTURE.:banghead:

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...