Jump to content
  • 0
nhlking

Camera.cfg change.

Question

Hello,

 

i had the problem with my prepar3d V4, that when i was in virtual cockpit, i got falshing textures. Like in this video,

 

 

I found the problem in the camera.cfg file. Your programm keeps adding a line to the virtual cockpit camera.

 

"NearClipOverride = 0.15 //42 entry for Immersion Manager"

 

Can you tell me for that is this line, and why is it there?

 

When i restart the sim, the line is automatically again in this file.

 

Best regards

 

Marcel

Share this post


Link to post
Share on other sites

16 answers to this question

Recommended Posts

  • 0

Hello, I'm facing very same problem. Unfortunately even after deleting the line/file or changing value from 0.15 to higher ones it rolls back after launchiung Prepar3D.

For now only solution for me is to turn off the immersion manager in addons but this turns off all the immersion effects.

 

EDIT

You can also delete camera.cfg every time before launching Prepar3D without deactivating immersion manager. This will keep the effects and no more flickering.

Edited by csb005

Share this post


Link to post
Share on other sites
  • 0

I am having the same issue. Flashing mountains... And today I did a flight from fsimStudios Cancun, and noticed the ground textures are flickering as well! After a quick conversation with the developer I found the issue indeed lies in this line!

 

According to the P3D SDK:

NearClipOverride float Greater than zero.
Default: Variable
Overrides the near clip plane of the camera. Units are in meters. Setting a near clip value too low could potentially cause z-fighting in the distance due to lose of depth buffer precision.
Edited by Er!k

Share this post


Link to post
Share on other sites
  • 0

Same issue here.  Been tearing my hair out to figure out why the flickering suddenly started.  Hope they find a fix.  I only have the NGXu package.

 

Steve Giblin

Edited by StewCal

Share this post


Link to post
Share on other sites
  • 0

Please, get this fixed asap. Meanwhile I've uninstalled everything from Parallel42 but something is still adding this darn line in the camera.cfg. What program/add-on/dll else could do so?

Share this post


Link to post
Share on other sites
  • 0

Temporary solution is to delete camera.cfg after every run of Prepar3D. The file is generated again and again but no flickering for me if it's newly generated. 

Share this post


Link to post
Share on other sites
  • 0
59 minutes ago, csb005 said:

Temporary solution is to delete camera.cfg after every run of Prepar3D. The file is generated again and again but no flickering for me if it's newly generated. 

I understood this. But WHY is this bug still present after I've uninstalled all immersion products. This should not happen at all.

Share this post


Link to post
Share on other sites
  • 0
21 hours ago, Aaron Brazda said:

where is this camera.cfg file, i cant find it?

 

I guess the file is cameras.cfg ( not camera.cfg). If so that file is in directory %appdata%\Lockheed Martin\Prepar3D v4.

Share this post


Link to post
Share on other sites
  • 0

Hello Keven,

 

same as written above "me too" also have the same anomalities  created by the entry which your program keeps adding as a line to the virtual cockpit cameras.cfg section every time ( as mentioned the "NearClipOverride = 0.15 //42 entry for Immersion Manager" line). In addition to the problems outlined already above I have another observation which is in the Co-Pilot PMDG NGXU Side window where there is a full almost vertical split when looking sideways out of VC  "over the left shoulder" through the back Co-Pilots window. Looking like the Window has a huge burst.

 

All goes away back to normal when I erase that line from cameras.cfg beore after the NGXU immersion started but before I launch my default flight from the P3DV4.5 start menu.

 

When do you exspect a fix for this to avoid this annoyance within your otherwise great program(s)?

 

Thanks, rgds

Andreas

 

 

Share this post


Link to post
Share on other sites
  • 0
On 4/2/2020 at 4:24 PM, RunShotgun said:

An update has been pushed. You can uninstall and reinstall Immersion Manager from OrbxCentral to fix the issue

Great. Thank you. I'll try soon.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...