Jump to content

Recommended Posts

So, I am pulling my hair out over trying to set P3D to run on the monitor/display I prefer. I have a two monitor setup in Windows 10. My primary display is a 4k display set to run at default resolution 3840x2160. It IS set as the primary display in the Windows Display Properties. My secondary display is a 2k display, running at it's default resolution of 2560x1440. Neither display is brand new or anything, and I have been using them with my system without issue for awhile. However, I switched my desk setup around, and now I cannot get P3D to run on the 4k display by default, when I start up P3D through either SimStarter or without SimStarter. I have Googled this issue until I am blue in the face, and I cannot find a suitable answer. All I want is P3D to run on the 4k display, and only the 4k display, when I run P3D. I am NOT wanting or trying to spread the display of P3D across both monitors or anything complex like that. I just want to run P3D and have it running on the single display I want without having to minimize and drag it from the 2k display over to the 4k display. 

 

I have tried over and over to ensure that in my P3D.cfg (both in SimStarter and the default P3D.cfg) that I have the correct display set within P3D, in my case display 0 which is my 4k display. Within both P3D and SimStarted, it says that P3d is to run on the display that I prefer, but that does not actually happen.

 

Has anyone else encountered this or have any suggestions? It is extremely frustrating. There has to be a way to fix this. All of my other applications run fine on the display that I prefer, but P3D refuses to. 

Please help....argh.....

Link to post
Share on other sites

Hi Doug, yes I have done all that, and ensured it multiple times. That said, I may have finally solved the issue through trial and error, but I am about to start and exit P3D a few times to confirm. I will report back if I have actually solved it.

 

Thanks for the suggestion.

  • Like 1
Link to post
Share on other sites

Okay, okay... I think I solved this bear of an issue. So, a few notices first....

 

1) In trying to troubleshoot this issue, I would start up P3D, which as explained previously, kept running initially on my second display, which I did not want it to. After multiple attempts, within P3D, setting it to run on my preferred display (and also ensuring the proper resolution was set), and then exiting P3D, I would then open up my Prepard.cfg file and delete any device entries for my secondary display, save and close it. I would also do this for my SimStarter prepard.cfg file. However, every time I did this and then ran P3D again, when exiting P3D and reopening the prepard.cfg (and the SimStarter one too) a Device entry for my secondary display would again be added. 

 

2) What finally solved this, is that AFTER deleting any entries in my Prepard.cfg for my secondary display, and BEFORE running P3D again, I had to swap the two displays where they were plugged into my video card. THEN I ran P3D via SimStarter (and without) several times, and P3D is now running consistently on my preferred display. 

 

Whew...what a puzzling and frustrating problem, but after lots of trial and error I finally got it sorted. Just wanted to post all this here in case anyone else ever runs into this issue.

  • Like 1
  • Thanks 1
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...