Jump to content

FlightSim.com review of Leeds Bradford Airport


Recommended Posts

  • 3 months later...

That reviewer is either easily pleased or just didn't check the airport properly. To give an airport with performance issues near the main terminal and missing taxiway lighting 10 out of 10 is really pushing it. The airport is unusable at night and the sim frame rate suffers hugely near the main terminal so it does not warrant a perfect score.

 

There is a great deal to like admittedly, excellent buildings, 3D grass, lots of surrounding scenery and ground traffic as well as the lovely runway which varies in height across its length. But until the glaring taxiway lighting omission is sorted and something is done to address the issue with the apron lights that drags the sim to its knees for some users, including people with i9 processors and a thousand pounds graphics card, it is in my opinion, an 8-10 airport at present. It could be a 10 out of 10 airport if the issues are fixed though.

  • Like 1
Link to post
Share on other sites
  • 3 months later...
On 5/16/2020 at 9:49 PM, cbcdesign said:

That reviewer is either easily pleased or just didn't check the airport properly. To give an airport with performance issues near the main terminal and missing taxiway lighting 10 out of 10 is really pushing it. The airport is unusable at night and the sim frame rate suffers hugely near the main terminal so it does not warrant a perfect score.

 

There is a great deal to like admittedly, excellent buildings, 3D grass, lots of surrounding scenery and ground traffic as well as the lovely runway which varies in height across its length. But until the glaring taxiway lighting omission is sorted and something is done to address the issue with the apron lights that drags the sim to its knees for some users, including people with i9 processors and a thousand pounds graphics card, it is in my opinion, an 8-10 airport at present. It could be a 10 out of 10 airport if the issues are fixed though.


There’s also no active ILS on either runway. There was on the default so I’m guessing it’s an Orbx issue. 
 

It’s a beta at best and it needs fixing otherwise I’ll hold off buying any further Orbx products. Hoping for a fix soon. 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...