Jump to content

london city X-Plane. Orbx EGLC London City Airport. But it's killed my frame rate.


Recommended Posts

X-Plane. Orbx EGLC London City Airport. But it's killed my frame rate. First, let me apologise again for the far to frequent use of the word fantastic. I will put a large yellow post-it on my monitor to remind me not to use it! And so we have a new Product from ORBX ie EGLC London City Airport. the download has a small error that they are working on regarding a Land rover file. I was so excited to see this airport arrive as it's my second home for Heli flying being the inroad to the great city of London. Now I will start by saying it might be me but with the same graphics settings that I usually run they have dropped on flat screen from 45 -50 to 9-20. at the moment it's virtually un-flyable for me. I have a 4.7 gig with 32 gigs of ram and a 1080 card. I think it's the type of system that many users will have?
Perhaps aircraft will not have the problem the Heli pilot has or I hope I find a problem on the PC but everything else is running fine ie Arma 111 and DCS so perhaps this is one stage too far in terms of detail and low flying. Fingers crossed it can be put right or as I said I hope it's me! I don't want to be paying for detail that I have to turn down just to be able to fly a Helicopter low down in London. I will still say what a fabulous job they have done I only hope it's me because London is starting to look beautiful in X plane with the ORBX updates.
Wonky Joystick Productions
A voice Made For silent Movies
Videos For fun
Link to post
Share on other sites

Perhaps this post would see more responses if it was in the X-Plane 11 support forum and not the Community Videos forum.

FYI my fps in the same area is around 40 but I am using a RTX 2080Ti video card.

Cheers

Edited by john548
Link to post
Share on other sites

I get 47 FPS at EGLC. If you are down to 7fps it’s because your video card’s memory is getting thrashed and XP11 is swapping to HDD or SSD memory. We need to avoid that happening.

 

Try moving your texture slider to ‘High’ instead of maximum when doing ops in the London area. Also reduce the reflections slider to zero or one. Finally just use MSAA 2XAA for your AA settings. Let me know what those three changes combined achieve for you.

  • Like 1
Link to post
Share on other sites
3 hours ago, John Venema said:

I get 47 FPS at EGLC. If you are down to 7fps it’s because your video card’s memory is getting thrashed and XP11 is swapping to HDD or SSD memory. We need to avoid that happening.

 

Try moving your texture slider to ‘High’ instead of maximum when doing ops in the London area. Also reduce the reflections slider to zero or one. Finally just use MSAA 2XAA for your AA settings. Let me know what those three changes combined achieve for you.

Thanks for the reply john but I have been through all that side of things. As recommended by another member on this group i deleted the preference folder and get 36 FPS on the ground instead of the 9-10. problem is it only works once next time you go into x plane you have to the same again to get London city working at the higher frame rate last night even managed it in ?VR. I think that somehow the xplane is being corrupted and left with garbage in the program on the second re boot. you can see it in a rather long video. Having just retired my previous job as MD and beta tester was for computerised telescope systems. so I have a reasonable knowledge about how things should work. but I feel that one of the updates in library or the airports or true earth might be causing the problem. as you will have seen from my videos I am a big fan of the Orbx software. But it changed on the after the download and deleting the preferance file shows it can run as it did the day before. From a number one Orbx fan I hope you can lead me in the right direction to fix it. regards Dave

 

  • Upvote 1
Link to post
Share on other sites
  • 2 weeks later...

Here is another one with the same issue. Without ORBX EGLC I have 45+ fps, with ORBX EGLC, fps go down to 11 fps. When I delete the preferences I get my 45+ fps back. After a new system start it`s going down again. This is the very first airport scenery with such a bad performance. And my machine is pretty decent, to say the least. 

Link to post
Share on other sites
  • 9 months later...
On 8/7/2019 at 7:47 PM, Christian11 said:

Here is another one with the same issue. Without Orbx EGLC I have 45+ fps, with Orbx EGLC, fps go down to 11 fps. When I delete the preferences I get my 45+ fps back. After a new system start it`s going down again. This is the very first airport scenery with such a bad performance. And my machine is pretty decent, to say the least. 

Is it in ALL airports?

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...