Jump to content
Sign in to follow this  
John Venema

Fix to Lord Howe Island installer

Recommended Posts

Lance sent me this link to an update which fixes the compatibility issues between Lord Howe Island and FTX. Note I have not tested this fix.

Hi John,

There is now a set of "fixed" files available which takes care of the Lord Howe installer issue.  I thought maybe you would want to add the link to the locked thread on that topic.  Otherwise I can create a new thread just so people can get the two working ok.  Here's the thread with the fixed files if you want to take a look. 

http://www.sim-outhouse.com/sohforums/showthread.php?t=67116&page=3url

Lance

Share this post


Link to post
Share on other sites

A comment from Nils states...'It's only sad that it wasn't intended to work with FTX together (at the same time).'

Can someone explain better? Does it mean that you cannot fly out of FTX and straight to LHI?

Share this post


Link to post
Share on other sites

Hi,

if you don't use my files and if FTX is enabled then the Lord Howe default.xml and AutogenDescriptions.spb is disabled.

If you don't use my files and if FTX is disabled then the Aerosoft default.xml and AutogenDescriptions.spb is active and Lord Howe works optimal (but Aerosoft replaces those two files of your FSX and they use not the XPack files, so XPack specific entries are missing).

If you use my files you can use both sceneries at the same time.

My files are for use with XPack + Lord Howe + FTX + VFR Germany at the same time. If you don't have VFR Germany or XPack it's no problem, you can still use my files to use Lord Howe with FTX. I hope it's understandable what i wrote :D

Personally i can't understand why they decided to use their own stuff for a small island and take the risk of replacing important files. But anyway, it's a nice scenery and perhaps Aerosoft and Orbx could find a better solution.

PS: Always make backup copies of the complete folders before you change something!

Share this post


Link to post
Share on other sites

Hmm, I wonder if LHI can accommodate AI aircraft?

Hmm, i'm not a scenery designer. I only guess that the ai would roll below the runway:

Posted Image

Share this post


Link to post
Share on other sites

;D

    I've installed the "fix", and it works great. With the fix I can leave FTX on, and fly straight from Sydney to Lord Howe Island with no problem, and superb scenery at both ends of the flight !

Thanks

    Sue

Share this post


Link to post
Share on other sites
Guest GaryVH-GJB

Hi Sue,

I just made the flight to LHI and when I arrived the scenery was alright but the tree textures were just square pictures of trees  ??? Did I miss something in the installation process. Everything else is correct except the tree textures.

Hope you can shed some light on what I did wrong

  Gary VH-GJB

Share this post


Link to post
Share on other sites

A addendum to my previous comment, where i stated that Aerosoft doesn't uses the XPack default.xml:

Another user seems to found out, that they would add their lines to the (default) default.xml but would save it in another format and that's why the file size would be much smaller (and no XPack entries would be missing).

It sounds logical to me, but i can't verify that, because i don't have the Aerosoft files anymore and i have no intention to get them and to compare every line to see if they are there and nothing is missing, especially after i read the political Aerosoft statements and i don't think it's my task as a user/customer to search for possible conflicts of Aerosoft add-ons with other Add-ons.

That should be done by the developers and if they change default files it should happen in a transparent and responsible way.

So bottom line: i still use my files to use FTX and LHI together and i'm sure that the XPack and the other entries are there.

I'm thinking of compiling the default.xml to spb to make sure that nobody could change them without informing me about the changes but then i would need another switch for FTX  ;D

@Gary

Did you disable FTX before you installed LHI and do you use my files? And do you use replacement textures for trees/vegetation?

I had no problems when i flew from Sydney to LHI.

It would be also helpful if you could post a screenshot of your problem.

Share this post


Link to post
Share on other sites
Guest GaryVH-GJB

The words "pain in the arse" come to mind lol...its not supposed to be this difficult!!!....I forgot to turn FTX off yes I used your files and the big trees were just black boxes with trees painted on them...so I uninstalled FTX and reinstalled ...and when I loaded up LHI I had no big trees but all the scenery was there.  ??? I have just uninstalled LHI  I may reinstall it later...I did a search of the aerosoft forums for ideas and help...but most of the blokes there have never even heard of FTX...so they were no help...anwho...thanks Nils for your reply to my hassle and hopefully I can resolve this issue soon.  :)

              Gary..VH-GJB

Share this post


Link to post
Share on other sites

Lol i'm pretty sure that there would be no LHI add-on if FTX would not exist, but anyways...

I started at Sydney and moved with the slew mode to LHI (i had not much time) and made a scenery refresh, but the only problem i saw there was the "famous" LHI hole (before and after the scenery refresh)..

I think that your problem is a texture issue. Next time when you install LHI ensure that FTX is disabled and allow LHI to install the modified textures. I hope this helps.

Posted Image

Share this post


Link to post
Share on other sites

;D

    I didn't let Lord Howe replace the tree textures. As I recall, it asked if I wanted it to..., said NO,

don't have square trees...  Definitely turn off FTX first. Install Lord Howe, the the fix files.

    Good Luck Gary !

                Sue

           

Share this post


Link to post
Share on other sites

Nils

Speaking as that other user, I don't blame you! My eyes about crossed doing the crosschecking and comparison - I'm still hoping to get confirmation from Sascha if my utf-16 / utf-8 hypothesis is right, It would have been nice to hear something from them earlier on though, so I'd not had to do the work - especially as the first comment seemed to confirm they were all doing what we thought they were.

I have the ftx side version of your files installed currently, as there's no way I'd want to fly in that area without FTX mode enabled, and am very greatful to you for doing the work of putting them out there in the first place!

Once we know how the AU Gold and other installers affect them, will you be issueing new ones if need be?

Share this post


Link to post
Share on other sites

I didn't have a close look at the bigger text file, but can confirm that the smaller binary file dies indeed NOT include Acceleration stuff. As to the text file, it probably doesn't either, changing the utf shouldn't make a file size difference. Good thing it's quite easy to fix this manually (or just get Nils' files).

Share this post


Link to post
Share on other sites

Aah, I can't speak for the binary file, not having the knowledge, I only checked the text file.

As for the UTF comment, if you read up on the utf standards, it definitely does, UTF-8 records western characters with a single byte, UTF-16 records them with two. If the installer has genuinely saved the file with a different encoding, it would change the size.

Srsly though, if you were either prepared to post, give info to John to post (as I know he posts there) or tell me what to post to prove things over the small file, I would love to call them out on it properly.

Share this post


Link to post
Share on other sites

Nils

Speaking as that other user, I don't blame you! My eyes about crossed doing the crosschecking and comparison - I'm still hoping to get confirmation from Sascha if my utf-16 / utf-8 hypothesis is right, It would have been nice to hear something from them earlier on though, so I'd not had to do the work - especially as the first comment seemed to confirm they were all doing what we thought they were.

I have the ftx side version of your files installed currently, as there's no way I'd want to fly in that area without FTX mode enabled, and am very greatful to you for doing the work of putting them out there in the first place!

Once we know how the AU Gold and other installers affect them, will you be issueing new ones if need be?

Thanks for correcting me, i'm not a developer, i only invested a lot of time and money in my FSX installation and i got "paranoia" because of add-on installer which altered my files without asking me or documenting their steps.

I'm looking forward to AU Gold and i will try my best to make it work together with LHI, because LHI without FTX makes no sense in my eyes.

But i would feel more comfortable if there would be an "official" solution.

And i would feel more comfortable if AS would change their "we don't give a sh## about other add-ons and your problems" attitude, because at the moment i can't imagine to buy another scenery from them. I have really tons of add-ons, but i have only issues with AS add-ons and their sceneries are covering only very small areas, so i really hope that they will change their attitude.

It's sad because LHI could be very cool.

Share this post


Link to post
Share on other sites

Nils, you little beauty :D.

Thank you so much for doing this, these are two products that need to be enjoyed together.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...