Jump to content

active TE GB South P3D v4 Stuttering/slowing performance issue


Recommended Posts

I have installed TrueEarth GB South and started with the settings that I had been using for FTX EU England.  Straight away I am seeing an issue where, unlike really jerky stuttering, this feels more like driving through a field that has the off puddle of treacle in it!  Only way I can describe it.  I have progressively dialled down settings from what casts clouds to autogen levels etc and none of these seem to fix it.  It's actually so bad that after a while, and not wishing to sound dramatic, it feels quite nauseating.

I transferred the flight to FTX EU Scotland and smooth as silk up there.  I have a powerful system bought last year and can run FTX EU England at quite high settings without issue.  In this case however even if I turn settings down I still get the problem.  Probably best seen in this video although it can be much worse than this.  Any advice would be most hopeful as the product looks beautiful but is unusable in my system at the moment.

 

Link to post
Share on other sites
  • Replies 211
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

To add to this: The named behavior makes me more and more suspicious it's the high compression of the aerial image which most processors (including mine) have difficulty to cope with. Under X-Plane, w

Hello Delly, the comments of all customers are noted and will be acted upon where appropriate.  

Disagree; it's entirely correct. I'd be the first to agree that this forum is an outstanding source of support; none better. Wouldn't dream of criticizing the guys who have spent months developin

Posted Images

Start form default P3D setting.. there is a recommended setting in the manual for GB TE.  That fixed the stutters for me:)   When you get the settings that work for you , Save them as "England TE settings"  so you won't have to do this every time you want to fly there. 

Edited by FireRx
Link to post
Share on other sites
5 minutes ago, FireRx said:

Start form default P3D setting.. there is a recommended setting in the manual for GB TE.  That fixed the stutters for me:)

 

Thanks for your reply FireRx….are you referring to the recommended settings in the TrueEarth GB manual?  I have tried those although my P3Dv4 has no "Large"  Level of detail radius so I have tried different settings for that one.

Link to post
Share on other sites
49 minutes ago, FireRx said:

I left that at default

 

Ah ok, how are you doing that?

 

I don't see any way of setting defaults in the control panel?  I have it set to Medium now and still getting the stutters and some pretty awful blurries.

 

Edited by Dreamsofwings1
Link to post
Share on other sites

For better TE performance :

-  fly low and slow

-  fair weather

-  max clouds draw distance Minimum

-  max Visibility 40 mls

-  clouds shadows off

-  LOD radius Medium

-  framerate locked at 20 

 

Link to post
Share on other sites
19 minutes ago, GSalden said:

For better TE performance :

-  fly low and slow

-  fair weather

-  max clouds draw distance Minimum

-  max Visibility 40 mls

-  clouds shadows off

-  LOD radius Medium

-  framerate locked at 20 

 

 

So is this an issue that many are seeing?  Seems you really have to restrict the sim to get it to perform e.g. what if you want to use real weather with Active Sky.   The FTX regions run well for me with quite high settings and although I was expecting TE to be a bit more demanding I wasn’t expecting it to have quite such a drastic effect.  

 

Link to post
Share on other sites

Great stuff, but one with the worst performance out there one stutter show... Frustrating to say the least...

(i7-6700K 4.5ghz / GTX 1070TI 8GB / 16 GB ram Corsair 3200mhz / several SSD evo drives) (running 2K display at 2560 x 1440)

Edited by awf
Link to post
Share on other sites

A bit frustrated with the performance. London is a slide show which is to be expected I guess, but take Birmingham for example... used to get 30-40fps at UK2000 BHX and FTX England but getting 10-15fps with TE which is a major hit difference and finding the frames very fluctuating in more rural areas.

 

Running at 4.1ghz and a GTX 1060 6GB

 

If turning autogen down it doesn’t seem to reduce the buildings to try and test it either which would be useful if struggling for frames?

 

Looks great but seems maybe ahead of its time in terms of being able to perform on today’s systems. 

 

 

Link to post
Share on other sites

Another top tip :lower the  LOD to less, even to minimum 

 

As you are flying low you don’t care about sharpness 30 + mls away. This will give your system also extra breathing space...

 

Combined with my the other things I mentioned above it will help Ti achieve a higher framerate and a smoother flying experience..

 

As most of you are also using AS Heatrow, here what Mathijs Kok has to say :

https://forum.aerosoft.com/index.php?/topic/143313-mega-airport-heathrow-professional-and-orbx-true-earth-gb-south/

Edited by GSalden
Link to post
Share on other sites
3 hours ago, IanHarr said:

In all honesty I can't see what you are complaining about. That video looks fine.

 

I am comparing it to what the sim was like before, just using FTX EU England.  As I said it can be worse.

Edited by Dreamsofwings1
Link to post
Share on other sites
7 hours ago, bruce e said:

Interested to know what your PC spec is CPU AND GPU.

Im running a GTX1060 6Gb and have had to really wind down my settings -  Still testing for best settings

 

I am running on an i7-8700k Oc’d to 4.7Mhz, GPU GTX 1080ti, 32gb DDR4 3000mhz RAM

sim installed to a1TB Samsung 960 EVO M.2 PCIe SSD

 

 

Link to post
Share on other sites

Am experiencing the same ‘disappointing but expected’ poor performance on a decent Spec Sim PC (i7 6700 @ 4.6 with a gtx 1080ti, 2TB Samsung ssd etc)

I spent hours yesterday going through & backing off settings...frame rates are jumping/spiking, stuttering is very evident and using any high spec aircraft has an impact on it also, to a point it becomes unflyable due to pauses.

 

Flying in my ftx eng/wales /Sco is great/performace is superb, but TEGB looks great but is mighty hard to get a flight in without stuttering, blurring etc and in my case it crashing the sim (never had a crash before in P3Dv4)

I feared this might be the case with P3DV4 not being able to handle TEGB well...looks like I will now have to move forward with my plan and run / test x-plane with the same TEGB South scenery.

It well may be x-plane becomes my ‘UK TEGB VFR Sim’ ...could be expensive running both sims, but I see no alternative if x-plane handles TEGB far better than P3DV4!

Anybody know if there is a discount for TEGB South for x-plane if you have already purchased it for P3DV4?

Edited by Capt Pugwash
  • Like 1
Link to post
Share on other sites
1 hour ago, GSalden said:

Another top tip :lower the  LOD to less, even to minimum 

 

As you are flying low you don’t care about sharpness 30 + mls away. This will give your system also extra breathing space...

 

Combined with my the other things I mentioned above it will help Ti achieve a higher framerate and a smoother flying experience..

 

As most of you are also using AS Heatrow, here what Mathijs Kok has to say :

https://forum.aerosoft.com/index.php?/topic/143313-mega-airport-heathrow-professional-and-orbx-true-earth-gb-south/

 

Thanks, I wil play with settings again to see if I can get a stable sim.

will be good to see if ORBX can come up with anything.

Link to post
Share on other sites

The recommended settings in the user guide have not changed for some years; they are the same as those published for PNW in 2016 for example, and are not specific to P4DV4.4

I have butter smooth performance in 'rural' areas, with these settings...

FXAA off     A4xMSAA    Anisitropic 16x   Texture Ultra

Resolution 2560x1440x32

Vsync: On (I have a GSync monitor enabled in nvidia inspector) Triple buffering on. I have dynamic lighting on, and vehicle cloud and building shadows on.

World settings as below.

However over dense autogen these settings need to be reduced. I'm playing with this and will post what works for me when I have tested a bit more. Caveat - check my specs in the signature, I have a middling set up, so as always, you need to tweak these for your own rig.

image.thumb.png.33eeb63938d4193747c6536bd0c2aa42.png

  • Thanks 1
Link to post
Share on other sites
11 minutes ago, Capt Pugwash said:

 

Flying in my ftx eng/wales /Sco is great/performace is superb, but TEGB looks great but is mighty hard to get a flight in without stuttering, blurring etc and in my case it crashing the sim (never had a sim crash before in P3Dv4)

I feared this might be the case with P3DV4 not being able to handle TEGB well...looks like I will now have to move forward with my plan and run / test x-plane with the same TEGB South scenery.

It well may be x-plane becomes my ‘UK TEGB VFR Sim’ ...could be expensive running both sims, but I see no alternative if x-plane handles TEGB far better than P3DV4!

I do wonder if you have a point here.  I wasn’t going to get TrueEarth for P3D because I feared that it might bring P3D to it’s knees.  Then when I saw it was available I couldn’t resist it lol

As more developers bring out addons for Xplane it is becoming tempting.  Until A2A turn their attention to Xplane however I am remaining in P3D.

I am hoping that Lockheed Martin can make some performance improvements perhaps.  Surely TE must be on their radar and it’s one of those situations where their customers can make a direct comparison with performance on their competitor’s product.

Edited by Dreamsofwings1
Link to post
Share on other sites
4 minutes ago, flying_fish said:

The recommended settings in the user guide have not changed for some years; they are the same as those published for PNW in 2016 for example, and are not specific to P4DV4.4

I have butter smooth performance in 'rural' areas, with these settings...

FXAA off     A4xMSAA    Anisitropic 16x   Texture Ultra

Resolution 2560x1440x32

Vsync: On (I have a GSync monitor enabled in nvidia inspector) Triple buffering on. I have dynamic lighting on, and vehicle cloud and building shadows on.

World settings as below.

However over dense autogen these settings need to be reduced. I'm playing with this and will post what works for me when I have tested a bit more. Caveat - check my specs in the signature, I have a middling set up, so as always, you need to tweak these for your own rig.

image.thumb.png.33eeb63938d4193747c6536bd0c2aa42.png

Thanks for posting that information.

 

My rural performance is better too but as soon as I go near a town, even with autogen wound down below the recommended setting, I see this issue.

Link to post
Share on other sites

Well I see that people with higher spec sims than mine (Capt Pugwash) are also having problems, shame! Until there is a “fix” I,ll be holding off future TE editions. (:

Re x plane. As a GA flyer I agree 100%with the comment    “Until A2A turn their attention to Xplane however I am remaining in P3D“

 

Long time Orbx fan so will hang in there and continue to tinker with settings

 

Link to post
Share on other sites

…same for me, flew into barren Welsh mountains and it was fine, then got to towns, cities with autogen and it stutters at any setting...I also dialled down ‘all’ my autogen but it had no impact on poor performance around suburbia!

I fully intend to try x-plane/TEGB in the same areas...

Love the TEGB product it looks great ...but, needs the sim to be able to handle it better, hopefully P3Dv4.5 manages to achieve the neccessary...

Edited by Capt Pugwash
Link to post
Share on other sites
16 minutes ago, Dreamsofwings1 said:

will be good to see if ORBX can come up with anything

It certainly would be helpful if the settings advice in the user guide was updated to v4.4.

It must be impossible to give definitive guidance when so much depends upon the CPU and graphics card installed, and the effect of using other scenery (which in the UK is very likely for the larger regional airports). Not to mention the complexity of the aircraft you are using, height above the ground and speed, weather engine etc.... 

However, if a simple table was given with a column for low-end. mid-range and high-end spec machines using a default airplane, fair weather and  settings used by beta testers that would be a starting point for experimentation. It would need to be updated fairly frequently, I suspect.

I have a feeling that P3Dv4.5 which is not too far away may go some way to address some of the issues of texture and autogen loading times from what I read here https://fselite.net/news/prepar3d-v4-5-reportedly-nearing-beta-testing/ Good to see Orbx and LM are working together on this - brilliant!

Link to post
Share on other sites
3 minutes ago, bruce e said:

Well I see that people with higher spec sims than mine (Capt Pugwash) are also having problems, shame! Until there is a “fix” I,ll be holding off future TE editions. (:

Re x plane. As a GA flyer I agree 100%with the comment    “Until A2A turn their attention to Xplane however I am remaining in P3D“

 

Long time Orbx fan so will hang in there and continue to tinker with settings

 

Yep, I am tempted to uninstall and ask for a refund but ORBX was one of the elements that made me take simming seriously again and I’ve loved using the FTX regions etc.  I am hoping that a solution can be found.  To be honest FTX EU England looks pretty damn good.  It might not be as accurate as TE for VFR but it looks great!  I moved to ORBX from photoscenery because I wasn’t keen on the flatness of it (solved in TE) or the ‘baked in’ images eg when you taxi past a blurred photo of an aircraft printed on the ground or see cars on the motorway driving over a photo of a truck.

There is no doubt that there is a use for TE, I think rural areas look stunning, and on a smooth platform VFR will be very realistic.  We just gotta figure out how to get this cat purring!

  • Like 1
Link to post
Share on other sites
3 minutes ago, flying_fish said:

 

I have a feeling that P3Dv4.5 which is not too far away may go some way to address some of the issues of texture and autogen loading times from what I read here https://fselite.net/news/prepar3d-v4-5-reportedly-nearing-beta-testing/ Good to see Orbx and LM are working together on this - brilliant!

 

I agree, also agree regarding the various systems.

I wonder if it’s as simple as a tweak in the P3D config file but not going there until someome more qualified suggests something :huh:

Link to post
Share on other sites
2 minutes ago, Dreamsofwings1 said:

 

I agree, also agree regarding the various systems.

I wonder if it’s as simple as a tweak in the P3D config file but not going there until someome more qualified suggests something :huh:

I was thinking of removing FTX eng and seeing if that laying under it is having an adverse impact on TEGB...have you tried that yet?

  • Thanks 1
Link to post
Share on other sites

I will try removing ftx eng & Wales later today and see if any improvement to TEGB, also will untick high res textures again just to test (did try this last night, can anybody see a difference with High res textures ticked/unticked?)...I will fly out of Birmingham and circle the City and run through all settings in an attempt to smooth out’ performance/visuals...

Edited by Capt Pugwash
  • Thanks 1
Link to post
Share on other sites
13 minutes ago, Capt Pugwash said:

I was thinking of removing FTX eng and seeing if that laying under it is having an adverse impact on TEGB...have you tried that yet?

Not tried that yet but definitely worth looking at.

 

14 minutes ago, BrianV said:

Try Nick's advice of unticking the "high-resolution terrain textures" in p3d. This does seem to help on fps. from my first flight this morning.

Interesting, so does this improve FPS but keep the visual quality of TE?

Link to post
Share on other sites
48 minutes ago, Capt Pugwash said:

also will untick high res textures again just to test (did try this last night, can anybody see a difference with High res visualsticked/unticked?)

 

Hello,

be aware that you will see no difference until your restart the simulator.

Once you have done this, the difference in RAM usage will be obvious.

 

Instead of lowering autogen settings, try lowering scenery complexity.

 

As an illustration only:

London, as viewed from above Gatwick, scenery complexity maximum.

2.jpg

 

London, as viewed from above Gatwick, scenery complexity minimum

4.jpg

 

 

Also, this is all good advice and should be heeded, not overlooked.

 

Quote

 

For better TE performance :

-  fly low and slow

-  fair weather

-  max clouds draw distance Minimum

-  max Visibility 40 mls

-  clouds shadows off

-  LOD radius Medium

-  framerate locked at 20

 

 

 

 

 

Link to post
Share on other sites
13 minutes ago, Nick Cooper said:

 

Hello,

be aware that you will see no difference until your restart the simulator.

Once you have done this, the difference in RAM usage will be obvious.

 

Instead of lowering autogen settings, try lowering scenery complexity.

Also, this is all good advice and should be heeded, not overlooked.

 

 

Morning Nick... Noted

I have created a seperate graphics settings profile for TEGB, and am going to go ‘right through it all’ again today...

I have a great setup with smooth flights in all other scenery, this appears ‘a bridge too far’ for the sim, but I shall persist with testing all settings, combinations and suggestions!

Great product by the way! we are now just attempting to iron out the creases we appear to have...

If you have it running smooth in all locations within TEGB, Please be so kind as to post your settings for us to try - tks

Edited by Capt Pugwash
Link to post
Share on other sites
1 hour ago, flying_fish said:

The recommended settings in the user guide have not changed for some years; they are the same as those published for PNW in 2016 for example, and are not specific to P4DV4.4

I have butter smooth performance in 'rural' areas, with these settings...

FXAA off     A4xMSAA    Anisitropic 16x   Texture Ultra

Resolution 2560x1440x32

Vsync: On (I have a GSync monitor enabled in nvidia inspector) Triple buffering on. I have dynamic lighting on, and vehicle cloud and building shadows on.

World settings as below.

However over dense autogen these settings need to be reduced. I'm playing with this and will post what works for me when I have tested a bit more. Caveat - check my specs in the signature, I have a middling set up, so as always, you need to tweak these for your own rig.

image.thumb.png.33eeb63938d4193747c6536bd0c2aa42.png

 

These are not the settings Orbx recommend for the True  Earth regions..

The settings I showed are settings advised by Nick when TE NL came out and it helped many people with performance.

 

You are posting Max settings ... 

 

Edited by GSalden
Link to post
Share on other sites
1 minute ago, GSalden said:

Useless for most people.

Sorry if this hasn't helped, as was it's intention... I also said:

1 hour ago, flying_fish said:

However over dense autogen these settings need to be reduced. I'm playing with this and will post what works for me when I have tested a bit more

..and that is what we are discussing here. I'm using Nicks helpful suggestions and testing for added payware too. It takes about 20 minutes to run each test, so hopefully you'll find more helpful advice as we go along and more posts appear. 

Link to post
Share on other sites

Another tip that helps reduce blurries on my system, set the texture size to minimum, 256 x 256.  I could fly from coast to coast at 3ookts and hardly see any blurries using this setting.  I don't know whether it helped my smoothness but I get smooth flight everywhere as soon as I'm away from London.

Link to post
Share on other sites
11 minutes ago, John Dow said:

Another tip that helps reduce blurries on my system, set the texture size to minimum, 256 x 256.  I could fly from coast to coast at 3ookts and hardly see any blurries using this setting.  I don't know whether it helped my smoothness but I get smooth flight everywhere as soon as I'm away from London.

 

I remember with FSX that I resized AG trees / buildings and clouds textures to improve the framerate and no one ever saw a difference in quality when flying higher than 2000 ft... 

Link to post
Share on other sites

I am downloading , this sounds like the pain I went through getting VR stable , looking forward to testing and seeing how my 2080 fairs , I know my processor bottlenecks the system in UK so will be interesting have not got high hopes but this is purely for VFR and hopefully the Q400 . 

The biggest thing  to me with VR was make sure disable full screen optimisation is ticked and run with a refresh rate of 30fps if your monitor supports.  

I can dip to 22fps sometimes lower and remain smooth . 

Link to post
Share on other sites

I am really struggling with TE, all the settings I try looking at the advice results in Blurries.  I guess its disappointingly back to FTX England for now.  Its a shame as it looks beautiful until you try to fly anywhere.  Hopefully some solid advice will come.  I have a 6700 with 32gb RAM and a GTX 1070.

Link to post
Share on other sites
2 minutes ago, Nick Cooper said:

Hello,

I doubt that your hardware is causing you a problem.

Have you tried all or any of the suggestions in this topic?

 

Hi Nick,

 

Yes I have so far.  I'll hang on until the dust settles on it all.  I have always been happy with FTX England.

Edited by bcrawley57
Link to post
Share on other sites
Guest
This topic is now closed to further replies.
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...