Jump to content
Airwolf

resolved KGPI Runway Floating - weird issues

Recommended Posts

Just now, Doug Sawatzky said:

Maybe try cycling it back to very sparse then load the scene then cycle back to Extremely Dense

I thought of that.  Unfortunately nothing.  I've tried many settings changes.  I have uninstalled, made sure the folder was gone and then reinstalled.  Oh I also have LVFR airports that have DL and all work as they are supposed to.  What is confusing is that there are no lights at the terminal what so ever.  DL or not.  I even tried spawning during the day and doing a time preview.  Just previews pitch dark like when you change it to night time.

Share this post


Link to post
Share on other sites

Ya, that's bizarre, I can turn them on and off at will with P3D settings, and I haven't seen any other users with light issues, so maybe a P3D issue? Are all the modules of your P3D updated to v4.4? 

Share this post


Link to post
Share on other sites
7 minutes ago, Doug Sawatzky said:

Ya, that's bizarre, I can turn them on and off at will with P3D settings, and I haven't seen any other users with light issues, so maybe a P3D issue? Are all the modules of your P3D updated to v4.4? 

Yes sir.  Completely clean install of 4.4.  Just deleted mt shaders for the heck of it.  No luck.  Oh well. Sucks I cant enjoy this purchase.  Thanks for trying.

Edited by tubbsds

Share this post


Link to post
Share on other sites
2 hours ago, Airwolf said:

Guys,

 

I have been very polite about this issue, but it has been almost 1 month and is there any fix in the horizon for the runway issues.  I can not even enjoy this addon, I feel I just paid money for the license and can not use it at all.  

 

I have excited to see an update for the addon today - installed it and low and behold - same runway issues.

 

Feeling neglected about support on this addon.  You have to see it from my shoes.  

 

Thanks

 

Hi

 

Have you responded to Greg's question in his above #15 post?

Share this post


Link to post
Share on other sites

Dave and Doug,

 

I have the same problem as Dave does. No lights. Object flow enabled, Dynamic lights both on and off, recycled scenery complexity, etc. Just posted so Dave knows it is not just his system. I will continue to try different settings and see if I can correct it.

 

Mark

  • Thanks 1

Share this post


Link to post
Share on other sites

And I'll chime in with the same issue, totally dark airport. All items above checked and double checked. I am going to try complete removal and fresh install and will report back.

Share this post


Link to post
Share on other sites

Hi guys,

 

For those of you missing lights at KGPI, be sure you have downloaded the latest orbxlibs.

 

This contains updates to all the dynamic light effects.

 

Cheers,

 

Greg

  • Thanks 1

Share this post


Link to post
Share on other sites

Hi Greg,

 

Thanks but there's more going on at GPI than lights, at least for me. I'll open a separate thread.

 

Thanks.

 

Edited by gsand

Share this post


Link to post
Share on other sites

Hi Greg,

 

My library version is 180725, and I've also run "Verify Files" just in case. The dynamic apron lights at KGPI are still missing, unfortunately. I've also tried uninstalling/reinstalling the airport.

 

BTW, I have no idea if that is relevant, but -- contrary to what was said in the announcement -- I had to install SODE manually after the update (and I can verify it's working fine for the dynamic ground poly).

 

Cheers,

Tym

Share this post


Link to post
Share on other sites

Greg,

Yes I have verified the orbxlibs.  I have spent hours and hours trying every setting I can think of and uninstalling and reinstalling from Orbx.  Nothing works.  I am also having issues at KIAD (lights display when you spawn there but dark when you fly in) and KMPS (terminal lights are always there but do not light up the AI aircraft ever, they are pitch black like the old days before DL).  At KSAN everything works perfectly when you spawn there (lights are on and AI is lit up beautifully), but when you fly in you can see the lights but they don't light up the AI (the aircraft are completely black like the old days).

 

Dave

 

 

Share this post


Link to post
Share on other sites

Greg,

Great job!  That libs update fixed KGPI, KMBS and KIDA!!!!!  3 for 1 fix!  They all work whether you spawn there or fly in!  I appreciate you listening and coming up with the resolution. 

 

Now only KSAN does not work for me upon arrival for another airport.  It works perfectly when I start the sim there but the DL does not illuminate the aircraft at the terminals when I fly in from another airport.  I was hoping this update would fix this airport as well but unfortunately it did not.  Matteo has tried and tried helping but no luck.  I guess the problem is on my machine.

 

When I start the sim at KSAN:

ViqnlNK.jpg

 

When I arrive from another airport:

jK4353G.jpg

 

Thanks again for the KGPI, KMBS and KIDA fix Greg!!

 

Dave

Share this post


Link to post
Share on other sites

I can confirm the Orbxlibs update has fixed lights at KGPI for me, too. Thanks Greg and the gang! :)

 

Tym

Share this post


Link to post
Share on other sites
On 1/1/2019 at 6:13 PM, Airwolf said:

Thanks Nick

 

But right on Turbulent site before KGPI got sold on OrbxDirect - they have this

 

KGPI Glacier Park International Airport v1.0.0.1

Compatibility

Fixed compatibility issue with Hervé Sors' navdata updates installed

Fixed ground poly z-fighting issues with third party camera software

 

I know it says Sors NavData - I bet that is similar to FSAerodata, the zfighting issues are still happening as stated in the above video.

 

In the above post - I have Nothing installed but Orbx and prepar3d 4.4.  No addons whatsoever.  Please check out the video

 

 

 

 

Hi mate,

 

Can you confirm that uninstalling (or disabling)FSAerodata resolves the problem? The solution that we included with the Turbulent version was actually provided by one of our users who had figured which core files were being modified by Hervé Sors' navdata.

 

No doubt, FSAD works at a similar level but as to which file(s) are modified, well that's beyond the scope of our knowledge. Bear in mind that KGPI was developed to be compatible both FTX Global and FTX NRM. If FSAD is indeed modifying core P3D files, then that is something that we wouldn't be able to accomodate.

Cheers,

 

Greg

Share this post


Link to post
Share on other sites

Hi guys,

 

Was out of town for work.  Yes, I disabled FSAD, and it everything seems to work.  Once FSAD is active, the elevation issue occurs.  I just wish everything would work flawlessly, can't enjoy things when all these conflicts happen.  

  • Thanks 1

Share this post


Link to post
Share on other sites

I too seem to having no dynamic lighting at KGPI if I arrive from another airport. I do have the latest Libs and updates. The building lights are on, and there are tall canopy lights that appear to be on, but the area where the planes park is completely dark. 

As vehicles drive (GSX) I can see the dynamic lighting on the ground, so I know the setting is correct in P3d. 

 

Any suggestions? 

Share this post


Link to post
Share on other sites

Hi Greg,

 

i also use fsAerodata and have an elevation problem.

 

If i disable "APX17140.bgl" from fsAerodata found at Scenery\0201and use the original APX17140.bgl all problems went away.

 

regards,

 

Harald

 

Share this post


Link to post
Share on other sites
On 2/13/2019 at 4:15 AM, bhorv67 said:

I too seem to having no dynamic lighting at KGPI if I arrive from another airport. I do have the latest Libs and updates. The building lights are on, and there are tall canopy lights that appear to be on, but the area where the planes park is completely dark. 

As vehicles drive (GSX) I can see the dynamic lighting on the ground, so I know the setting is correct in P3d. 

 

Any suggestions? 

 

Hi mate,

 

Rest assured we're looking into this - we'll let you know as soon as there's something to report.

 

Cheers,

 

Greg

 

Share this post


Link to post
Share on other sites
8 hours ago, Greg Jones said:

 

Hi mate,

 

Rest assured we're looking into this - we'll let you know as soon as there's something to report.

 

Cheers,

 

Greg

 

Thanks - In reading an earlier post (by you maybe?) there was a note to check to see if Object Flow is enabled in FTX. For me it is. There was also mention of a setting inside P3d, in the addon menu for Object flow - this I do not have. Is that a problem?

Share this post


Link to post
Share on other sites

Yes, that would be a problem. Also, if your username has a character such as "&" it will not work.

 

You should have 3 files for OF2 to work: 

 

OF_Config.xml in P3Dv4\ORBX\FTX_AU\FTXAA_ORBXLIBS\Scenery

 

Orbx_ObjectFlow_x64.dll in C:\Users\[YOUR NAME]\AppData\Local\Orbx\FTXCentral\newest version

 

add-on.xml in C:\Users\[YOUR NAME]\Documents\Prepar3D v4 Add-ons\Orbx ObjectFlow 2

 

 

Share this post


Link to post
Share on other sites

I feel for the guys at TD. KGPI or KFCA is a great addon but sadly it is prone to these weird issues. I had some of these issues when it was just under TD and the issues got resolved. But now I am back to having weird iusses of floating runways when flying in and snow covered ground when starting off. I too have a file labelled FSAD which I have no idea how I got except I think it might of been when I updated my AIRAC with Navigraph. I am hopefully that the guys can fix the floating runway/ditches around harden serfaces and the Z bais snow covered ground issues when having the airport listed as KGPI from the control panel.

Share this post


Link to post
Share on other sites

Hi,

i use fsArodata and had elevation problems also at KGPI.

 

I've disabled fsAerodata, reopened fsAerodata Configuration Tool and chose options,

unchecked "ICAO Identifiers" and enabled fsAerodata again.

 

This solved my elevation problem

 

regards,

Harald

 

 

 

 

fsAerodata Options.JPG

Edited by Harry320

Share this post


Link to post
Share on other sites

I see that you have posted the same question again without answering the question asked.


 

Quote

 

Hello,

are you also a user of aerodata or another program that changes default airports?


 

 

Share this post


Link to post
Share on other sites

Just to add my "+1" with using Herve Sors updates... Renaming the APX17140.bgl to APX17140.off in Prepar3D v4\Scenery\0201\scenery, has resolved the elevation issue for me... I'm not sure what functionality I may be losing because of this... Hopefully none as the scenery library should now be solely reading the Prepar3D v4\ORBX\FTX_NA\FTX_AA_KGPI\Scenery bgls

 

Disabling the above bgl also resolved some bizarre "top-down" view issues... where at a certain zoom level, the apron would randomly cover in snow, and I would have outline images of GA aircraft... Almost like it was a satellite photo.

 

Credit to the original user in the old TD forum that lead me down this path... I did see a note of a patch on the old TD forum that corrected this and was hoping for a port to the Orbx version.

Share this post


Link to post
Share on other sites
5 minutes ago, Nick Cooper said:

To be honest, you would be better restoring the original APX17140.bgl.

 

Quite possibly, and there is an "APX17140.bgl.ilsbckup" file created, however I cant be sure that the backup is the default bgl that ships with P3D, or whether it is a backup of the his previously modified bgl from the last time I did an AIRAC update. For troubleshooting, I chose to disable the file entirely. I'm no scenery dev, but hopefully this default world scenery bgl can be excluded somehow by yourselves.

Share this post


Link to post
Share on other sites

Hello,

the problem is that APX17140 .bgl also contains dozens of other airports in Montana and many other states.

It's fine if you manage to never visit one.

 

The Orbx product is designed to exclude the default Glacier Park, KFCA which of course it does.

However, the change to the default APX17140 .bgl adds KGPI, which is not in the simulator default

database but is in the same place and it is therefore not excluded by the KFCA exclude which cannot see it.

This allows the new KGPI data to interfere with the Orbx product, causing the anomalies that are the

subject of this topic.

 

Attached is a default copy if it is of use to you.

APX17140.bgl

Share this post


Link to post
Share on other sites

I see the problem. Would changing the ICAO code back to KFCA in the Orbx config resolve the issue? Is a fix actually possible for those that like to update the default AIRAC?

Edited by HammerTime

Share this post


Link to post
Share on other sites

Changing the control panel back to KGPA will not help because the KGPI amendment

would still be there. It's affecting the airport only because it is not excluded by the Orbx

product which has excluded the default airport only.

 

Even a blanket exclude of everything would not help because "everything" is only everything

in the default simulator and the Herve Sors modification has effectively introduced another addon.

Because the APX file that it is in is below everything else, it cannot be stopped from influencing the

airport. It has to be below everything else to change the navdata and I would guess that KGPA has been removed.

 

I would guess that if Herve could exactly match the Orbx product data, then its influence would no

longer be noticeable but it is only a guess and would probably involve some contact between the two developers.

Share this post


Link to post
Share on other sites

Is this a conversation that Orbx would be willing to broker? Herve provides his updates to users at no cost and out of the kindness of his own heart. However this is seemingly affecting fsaerodata users as well, which is a paid-for product in its own right. In the true spirit of the wider flight sim community, it would be great to see this fixed and it would certainly be better correcting "at source" as opposed to end-user attempted workarounds. 

 

I'll post back when I've tested the bgl backup that was created (if you would find this useful) because I don't like the idea of losing airports in their entirety :)

Share this post


Link to post
Share on other sites

I hope the dev team can discuss with FSAeroData team and find a solution.  I am sure it will be an easy solution.

 

 

Edited by Airwolf

Share this post


Link to post
Share on other sites
18 hours ago, Nick Cooper said:

Hello,

are you also a user of aerodata or another program that changes default airports?

I am not and it looks like this.

 

5.jpg

 

I do not use aerodata, I did install navdata from aero.sors.fr/navaids3 for NA, have however restored the APX1740.bgl file from the bkup that was made from that

install. I have tried many things that was mentioned in this forum but all to no avail. I have now uninstalled this scenery and will wait for a solution. Worse

now my default scenery for kgpi is also all messed up.

 

Thanks for trying to find a way to fix all this.

 

 

Share this post


Link to post
Share on other sites

Hello,

There is nothing the matter with the scenery.

I have explained in detail why using software that modifies default FSX/P3D airports

causes this and how to resolve it.

There is no default scenery for KGPI, which is the reason behind this error.

If KGPA is "messed up", I commend to you the file attached to post 73.

 

Share this post


Link to post
Share on other sites

Hi guys,

 

As the developer on the KGPI team responsible for this 'backend' stuff, I can confirm that what Nick has posted throughout the thread is correct.

 

Both Herve Sors' and the fsAD products appear to update the P3D core files. It's generally considered by developers that updating core files is a bit of a no-no and any software that does so, should come with a backup/restore function and a significant warning that modifying these files can (and likely will) cause problems with other addons. Trust me, if modifying the core files were an option, it would have resolved many of the problems faced by airport developers with these kinds of complex airports.

 

It has been suggested a number of times, both by Nick and other users, that the solution to this is to restore that original core file - in this case, APX17140 .bgl. I've examined this file and, although there are roughly 30 airports included in the file, only KGPI/KFCA is one that is likely to have required any updating of the sort offered by these packages. Therefore, restoring this file will only affect Glacier Park.

 

It's worth noting that, even if we were able to make the two work together, the updated info would NOT correctly match our Orbx airport anyway (the elevation is different by a few feet).

 

It's simply not practical for us to provide fixes and updates for the many permutations of externally modified files available now and into the future. It's tough enough to work with what we know without also having to account for whatever other obscure products might be out there.

 

The final answer therefore is, as Nick suggested, restore the file in question and all will be well with the world!

 

I'm sorry if this is not the answer you're hoping for but it's the best that we can offer.

 

Cheers,

 

Greg

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...