Jump to content

Recommended Posts

I'm 84 and did.  Overall, in my opinion it is better than FSX and now virtually all the products on sale will work with it.  Originally, it could be a damn nuisance because most addons wouldn't work with it...including Orbx.  And many here will perhaps remember the pickles I was getting myself into!:rolleyes:

 

However, that was soon rectified and most other suppliers have caught up too, so I thoroughly recomment it.

 

John 

Share this post


Link to post
Share on other sites
3 hours ago, JohnY said:

And many here will perhaps remember the pickles I was getting myself into!:rolleyes:

I remember John :) And I was so happy to see you persevere through it all.

 

3 hours ago, joemills said:

I`m a kid in my eighties, is it worth my while installing P3d?:unsure:

As for you Joe, go for it! What have you got to lose at this point? Have some fun! 

Share this post


Link to post
Share on other sites

I'm one of the young guys (75). I've run both sims since the beginning. On the one hand I think FSX is just fine. On the other hand I agree with Sinper 31. At our age, what the hell, go for it. The worst thing that can happen is that you decide it was a mistake. But, if you're like me, many things in life have been a mistake and this doesn't even rank on the top 1000..........Doug

Share this post


Link to post
Share on other sites

If your pc will take it, then it must be worth trying the new V4. I intend to get it, but will keep FSX active on a different drive for a while at least.

Share this post


Link to post
Share on other sites

Hi I have at the moment FSX:SE but I'm thinking of upgrading to P3D V4 when it's released, would it be possible to transfer my Orbx products (Global, Vector, Open Lc's) to P3D V4 for free or can you only do it from a previous P3D Version.

 

Thanks.

Share this post


Link to post
Share on other sites

Hello,

All FTX products are compatible with both versions of FSX and all versions of P3D.

Soon after P3D v4 comes out, there will be an update to FTX Central and then they

will be compatible with P3D v4 as well.

You cannot use the same files for FSX and P3D but FTX Central will install the correct files

at no extra charge.

  • Upvote 1

Share this post


Link to post
Share on other sites

Many thanks for all your replies and am seriously thinking of taking the plunge when V4 is available.

I`m normally a chicken but this chicken will fly P3D.

Thanks again guys.

 

Joe

Share this post


Link to post
Share on other sites

Joe.  Use the migration tool at your peril with P3D.  It sometime works but can also really mess your simulator up.

 

Use only Scenery (which is easy) All addon scenery can be used with P3D, but my experience is that aircraft must be compatible.

 

John

Share this post


Link to post
Share on other sites
4 hours ago, JohnY said:

Joe.  Use the migration tool at your peril with P3D.  It sometime works but can also really mess your simulator up.

 

Use only Scenery (which is easy) All addon scenery can be used with P3D, but my experience is that aircraft must be compatible.

 

John

Thanks John,

Is addon scenery added as in FSX?

Joe

Share this post


Link to post
Share on other sites
4 hours ago, JohnY said:

Use the migration tool at your peril with P3D.  It sometime works but can also really mess your simulator up.

Not always so...the migration tool can and DOES work perfectly for many users, without any complications. :)

Share this post


Link to post
Share on other sites
11 hours ago, Nick Cooper said:

Hello,

All FTX products are compatible with both versions of FSX and all versions of P3D.

Soon after P3D v4 comes out, there will be an update to FTX Central and then they

will be compatible with P3D v4 as well.

You cannot use the same files for FSX and P3D but FTX Central will install the correct files

at no extra charge.

I was wondering also how much this was going to cost and how to transfer FSX to P3D v4...So, thank you very much for all these excellent news !

Regards,

Richard Portier

Share this post


Link to post
Share on other sites
16 hours ago, Nick Cooper said:

Hello,

All FTX products are compatible with both versions of FSX and all versions of P3D.

Soon after P3D v4 comes out, there will be an update to FTX Central and then they

will be compatible with P3D v4 as well.

You cannot use the same files for FSX and P3D but FTX Central will install the correct files

at no extra charge.

Thanks Nick, waiting for more reviews on P3D before I make the jump,performance is the biggest complaint with FSX-SE now, loving the performance of Aerosoft FS2, I have a pretty good setup, and the load times for FSX-SE are terrible, it runs smooth on my system

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...