Jump to content
Sign in to follow this  
pphibbs

Simulator freeze on selection of alternative aircraft

Recommended Posts

Hi Guys,

 

I'm hoping someone out there has experienced the issue I've been having for the past couple of months. It is most frustrating as it goes away for a while only to return unexpected without any changes to the sim. I'm running FSX boxed version with the Acceleration add on. OS is Win7 64bit with a I7 based computer with 12gb RAM and a NVidia 580 with 3gb RAM. I have plenty of disk space and keep it tidy and defragmented. I don't run other software, apart from the usual antivirus and defrag software, on the computer to keep it efficient for the sim.

 

When the sim is working OK I have no issues with performance or the FSX, FTX, Active Sky or aircraft installed. I get excellent framerates sometimes exceding 200 in places. I have comfortable frames in airports like Melbourne, Brisbane to illustrate the impact of Orbx scenery in those areas as an example.

 

Therefore, I don't believe any of my software is behaving badly (apart from the issue I'll outline below - that comes and goes without any pattern I can discern).

 

As a further comment, I have ensured all my Windows updates are correct and that all device drivers, e.g., graphics etc, are up to date. I also clear the TEMP folder of unnecessary files and "Clean up the drive" as part of the Drive maintenance options.

 

The problem: When it occurs, I use one of the default Cessna aircraft in Cold and Dark config as the Default load for FSX. This is a starting point for loading the aircraft I want to fly ( a common technique for using more complex aircraft). On selection of the aircraft (and this can be as simple as selecting BOB, the cockpit or aircraft textures start to display but for external views only a black silhouette appears or for internal, the gauges are all missing and some of the internal textures are just black. Then the simulation freezes, with no choice but to reset the computer if in full screen or kill the application if in windowed view.

 

If it load the desired aircraft in the opening screen (as opposed to accepting the Cessna) the simulator functions as expected, i.e., there are no issues.

 

I've searched other forums but can't find anything that matches my issue. Haven't found anything on these forums either. I did post this issue when it first appeared after I installed FTX Global thinking it was caused by it but it has returned on a number of occasions and has disappeared many times after all Orbx products have been installed correctly. I don't believe the scenery software is at fault here.

 

Can anyone advise if they have experienced this issue and how they fixed it please?

 

Regards, Paul

 

 

 

 

Share this post


Link to post
Share on other sites

Hi Paul

 

When was the last time you deleted the shader folder and let FSX build a new set? Maybe worth a try? :)

 

Cheers

 

Doug

Share this post


Link to post
Share on other sites

Hi Doug,

 

Firstly, thanks for your thoughts.

 

Interesting ... what's the "shader folder" and where does it live? Will it upset anything if I delete it?

 

Regards, Paul

 

 

Share this post


Link to post
Share on other sites

Might be a good idea to pop over to 'Control Panel\All Control Panel Items\Administrative Tools' and have a look in the 'Event Viewer', should tell you exactly what went wrong.  Work from there, guessing is not a good idea,

Share this post


Link to post
Share on other sites

Thanks Chris. I live in the Event Viewer. Particularly when identifying Fatal Errors, OOM and CTD issues. Unfortunately, no error message is associated with my situation.

 

Good thought though. Thanks for responding.

 

Regards, Paul

Share this post


Link to post
Share on other sites

Have you tried something different to the Cessna for your 'cold and dark' startup? E.g. the default Beaver or even a simple freeware aircraft?

Share this post


Link to post
Share on other sites

The shaders folders are to be found at 

C:\Users\your name\AppData\Local\Microsoft\FSX

Shaders and Shaders 10, you can delete them, they will be rebuilt

when FSX starts.

The Shaders folder is for Direct X 9 and the Shaders 10 folder

for Direct X 10. Don't worry if there is only one folder.

Share this post


Link to post
Share on other sites

Thanks Nick. It's currently working at the moment but as soon as it happens again, I'll see if this action works.

 

Regards, Paul

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...