Jump to content

active Lclookup.bgl error


Recommended Posts

My FSX won't start - 'The 'Lclookup.bgl' file is missing or damaged. Please reinstall Flight Simulator to restore or repair the file. Flight Simulator will now exit.'

 

In FTX Central 2 I get a red flag saying  - 'Terrain configuration error - the terrain.cfg file doesn't contain a [landclasses] section. Please make sure you have the latest Orbx Libraries installed'.

 

Library files are up to date.

 

I am working with most Orbx add ons though error has come up today with first use of the recently purchased NZ North Island.

 

Order Number: FSS0449571
Order Date: 2016-01-01

 

Help please.

Edited by amerlyn
Link to post
Share on other sites

Hi there,

 

I don't see how the NZNI installer would have caused this issue but, in any case, I'd suggest two steps:

 

1. Reset your terrain.cfg file as per this thread: 

 

2. Start FTX Central v2, select Oceania, and then press Apply Group. This should restore the missing lclookup.bgl and re-insert the required custom terrain.cfg entries.

 

Let us know if that fixes the issues.

 

Cheers, Holger 

Link to post
Share on other sites

Hi Holger

 

That has cleared the red flag messsage within FTX Central V2 though am still  getting the same 'Lclookup.bgl' file is missing or damaged' error when trying to start FSX.

 

All seemed fine after installing the newer add ons after purchase, so don't know why the problem has suddenly cropped up today (nothing has been installed since).

 

Plse advise - thanks

Link to post
Share on other sites

Hi there,

 

lclookup.bgl is a small file that resides in \Scenery\BASE\Scenery. Do you have that file in that folder? If yes, what is the file date and size?

 

If not, check whether you have a lclookup.bgl in \ORBX\Scripts\Backup. If so, copy & paste that file into \Scenery\BASE\Scenery. If not, navigate to \ORBX\Scripts\Custom.au instead and copy & paste that version of lclookup.bgl into \Scenery\BASE\Scenery. Either version should work to allow FSX to start.

 

Cheers, Holger

Link to post
Share on other sites

Hi Holger

 

The file was missing  - I've installed it as suggested. Thought it had worked as FS now starts. However, it crashes with 'Microsoft Flight Simulator has stopped working' error a few minutes after I hit 'Fly now' (flight doesn't actually load) . This is happening every time, even when loading a simple default flight. Another thing I've noticed is that the FTX Central v2 icon is corrupted (just a MS default icon) even after refreshing desktop (though no error messages evident when using FTS Central to set different groups).

 

Regards

 

Antony

Link to post
Share on other sites

Hi there,

 

sorry, I don't know what specifically would cause those crashes. The fact that your lclookup.bgl got deleted somehow indicates that there may be a bigger issue with other core files as well, which might be easier to fix by reinstalling the sim rather than trying to check many different files that might be involved.

 

Does the crash occur with any flight situation, regardless of location and date?

 

You could try downloading the latest Orbx Libraries -- https://www.fullterrain.com/support#Orbxlibs -- and reinstall those. That should bring back the FTXC v2 icon but I doubt it will help with the crashes.

 

Cheers, Holger

Link to post
Share on other sites

Hi

 

The only flight I've managed to launch is one of the missions (the first listed with the microlight  at KEDW). Any other flight fails to launch regardless of aircraft/location. Thelibrary files are up to date, and still no icon either.

 

I've not meddled with anything - very sad if I'm going to have to reinstall everything - miserable weeks of reinstalling hundreds of add ons!

 

How do I safely uninstall ORBX scenery as no uninstallers visible anywhere?

 

Regards

Link to post
Share on other sites

Hi there,

 

are you running some kind of antivurus software that may interfere with file changes and movements? 

 

To manually add a new FTXC icon go into the Windows Start menu, then navigate to All Programs > Orbx, right-click on "FTX Central 2" and select "Send to > Desktop (create shortcut)".

 

You could try setting FTX Central to Global without the hybrid checkbox, which will return FSX back to default status. In addition, you need to separately uncheck the ORBX!OPENLC entries in your scenery library menu to deactivate all openLC sections. 

 

If doing so allows you to start all kinds of flights then at least we know that one or more of the Orbx add-ons are involved in the problem.

 

Cheers, Holger

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...